Netherlands ISDN?

Answered Question
Apr 29th, 2008
User Badges:

I'm trying to deploy a small CME setup in the Netherlands. I built a 2851 with a pair of 2BRI-NT/TE interfaces in the lab in the UK, and everything tested out just fine using some British Telecom ISDN2 lines. I've moved the kit to the Netherlands, and I'm about tearing my hair out trying to figure out why it DOESN'T work here.


I have three ISDN2 lines from KPN Telecom, currently plugged in to a KPN Telecom supplied and managed mini PBX (a Vox Novo, specifically - this is what the CME system is to replace). The ISDN lines appear to work fine connected into that PBX. KPN says they're just regular ISDN2 lines, nothing unusual. They did mention they're "point to point" links, but isn't that just default anyway?


If I move the cables across to the 2851, layer 1 shows active for the BRI ports, but layer 2 shows "NOT activated". If I turn on Q921 debugging, I can see the router sending IDREQs out when I clear the interface or unplug and reconnect the ISDN cable, but it's not receiving anything back from the telco. This is the same on all three lines.


There's a troubleshooting document on CCO "Troubleshooting BRI Layer 2" which suggests checking the ISDN switch-type first. I believe basic-net3 is correct but I've tried all the others out of desperation anyway, and nothing changes. That same document suggests restarting the router (tried that anyway), and for the symptoms I describe it says call the telco. Have you ever tried calling a telco and speaking to anybody useful the afternoon before a two day public holiday? They get even less helpful when they realise you're trying to retire their PBX so you can cancel the service contract!


So, can anybody who has sucessfully configured a BRI port for voice on a KPN Telecom ISDN2 circuit share any suggestions, or ideally show me the config for a working BRI port? This is the config I'm using on one of them right now, and this worked just fine for a BT line:


interface BRI0/0/0

no ip address

isdn switch-type basic-net3

isdn point-to-point-setup

isdn incoming-voice voice

end


Thanks!

Correct Answer by paolo bevilacqua about 9 years 3 months ago

Hi,


just configure "isdn static-tei 0" under bri interface and you will be fine.

Then you can configure the interface under a trunk group to simplify DP, translations config, etc.


Hope this helps, please rate post if it does!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
paolo bevilacqua Tue, 04/29/2008 - 07:58
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


just configure "isdn static-tei 0" under bri interface and you will be fine.

Then you can configure the interface under a trunk group to simplify DP, translations config, etc.


Hope this helps, please rate post if it does!

paolo bevilacqua Tue, 04/29/2008 - 08:48
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

That TEI issue happens all the time. Thanks for nice rating and good luck!

Actions

This Discussion