mcast from neighbouring PIM domain

Unanswered Question
Apr 29th, 2008
User Badges:

All, pls help.


We have mcast data coming to us from other domain (no control and unlikely they will change smth for us). Our router is configured as a PIM-SM leaf router restricted to SPT and configured with static RP.

We want to distribute that data using our own PIM domain. How can we "take" the data from leaf router and forward using our PIM domain ?


Any help is highly appreciated.

HtH

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
Harold Ritter Sun, 05/04/2008 - 07:06
User Badges:
  • Cisco Employee,

Alex,


If there is not many groups, you can just configure "ip igmp static-group x.x.x.x" on the interface that faces your network on your router connected to the other domain.


This way you can configure your own PIM-SM domain.


Regards,

aspodinets Sun, 05/04/2008 - 08:17
User Badges:

Thanks, Harold,


This is really a good way, but I have about 60 groups to forward. I afraid this will cause high CPU load on our 3750s. But will try if no other way.


Maybe you have other ideas?


Regards

cisco_lad2004 Sun, 05/04/2008 - 09:23
User Badges:
  • Gold, 750 points or more

If u are totally different domains, you might want to look at MSDP.

basically you have your own RP which pulls from your Sending Domain RP. PIM sparse mode ( no assumptions this time :-) ) still needs to be configured at boundaries.

with MSDP u have more control ( I have never tested it ).


http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_35_se/configuration/guide/swmsdp.html#wp1026174



HTH


Sam

aspodinets Sun, 05/04/2008 - 10:31
User Badges:

Thanks, Sam,


We're using MSDP for other domain, and it's working good. For the particular domain I want to forward from - they're unlikely to run MSDP with us.


I'd appreciate more ideas.


HTH


Alex

cisco_lad2004 Sun, 05/04/2008 - 10:46
User Badges:
  • Gold, 750 points or more

How about using Harold's suggestion for static join, but with a slight twist. use an ACL.

"ip igmp access-group" then u have less lines to add and more control when it comes to troubleshooting.


With regards to CPU load, I don't see why it would be any different from forwarding 60 groups straight out.


what I suggest is that you start with a restrictive ACL, so 10 groups for example. Monitor then relax it ...until u cover all 60 groups.


HTH


Sam

aspodinets Sun, 05/04/2008 - 11:24
User Badges:

Sam,

It looks like the only option now. Unfortunately my 3750 with 12.2.25 SEE4 doesn't allow to use "ip igmp access-group" with access lists, only single IP or *. :(


Honestly, I was hoping to find any additional ideas. Maybe someone has some trick in his hat ;).


I have already tried the way with "ip igmp access-group *", it required me to set a mroute like 0.0.0.0/0 (Remember ther 60 groups, there is 60 different sources :) ).


As a result I got CPU load risen to 40-50% (while usual was 7-12%). And had more trouble with data consistency.


HTH

Alex

cisco_lad2004 Sun, 05/04/2008 - 11:54
User Badges:
  • Gold, 750 points or more

Alex,


I can see ur predicament.

The only way you can get rid of the 60 sources is to use sparse mode and RP. but since no MSDP is allowed, this cannot be.

I can only see the use of static join for all.


with CPU, I have 4510 running at 70% constantly. as long as I know what they are doing and that it is the baseline I am not worried. high CPU is acceptable as long as other tasks are carried out and the trend baselined.


I look forward to seeing more input from other readers.



Sam

Harold Ritter Sun, 05/04/2008 - 15:05
User Badges:
  • Cisco Employee,

Alex,


I do not think that specifying 60 or so "ip igmp static-group" commands on the interface should cause any issue. No more than if the joins where sent by a downstream router anyway.


Regards,

aspodinets Sun, 06/08/2008 - 04:09
User Badges:

All, after a continuous testing and tries I have come to multiple problems:

1. With "ip igmp join group set", joined flow stops after a time-out.

2. The flow being transmitted over PIMs has about a half of the data that original flow has.


What could cause this ?

Actions

This Discussion