How to revert CIsco 871 back to SDM?

Unanswered Question
Apr 30th, 2008

I tried following the info on this page but no use:

the above tutorial instructs to put the pc into DHCP and then open the webpage blah

but the router's dhcp server is not will it give out an ip address...

maybe I am missing something...

any suggestions from anyone on what I might be doing wrong.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Mark Yeates Wed, 04/30/2008 - 14:53

Is this a new router with the default SDM config, or an existing config? SDM when first installed it puts a minimum configuration that does include DHCP for inside clients. If this does not have the config, and you have a subnet created on the router you can give your PC a static IP so that you can configure one VIA SDM.

If you need more help please post your config.


elliott-jey Thu, 05/01/2008 - 05:23

hello Mark,

I am new to cisco products. This is a new router

As per the instructions on the following page, it says connect the pc to any of the ethernet 10baset i attempted to connect to FE0 ~ FE3 and the pc did not get an ip given to I tried connect the pc to FE4 and still nothing, then I configured the pc to (static) and attempted the same from FE0 thru FE4 and upto FE3 nothing, FE4 worked!!

so now I got the SDM working.....but FE4 is a wan link, and I would like to connect the router to PPPoE via FE4 (WAN) port and SDM warns that once I enable PPPoE I would loose SDM connectivity via FE4....but FE0 ~ FE3 appears to be shutdown......what gives?

by the way, SDM express works and SDM also...

mlitka Fri, 05/02/2008 - 05:34

Do you have a device plugged into Fe0 - Fe3? If not they will appear as down. Try plugging another device into one of those ports and hitting the SDM page from them.

elliott-jey Fri, 05/02/2008 - 05:51

yes I did try that.

I tried by configuring the pc as static and then plugging in from Fe0 till FE3 nothing...

and then configured the pc as dynamic ip address, and repeatded the drill..still nothing.

not sure whats up.

mlitka Fri, 05/02/2008 - 06:29

When you plug the PC into another port does the port report as up? Where do you have the IP address configured on the FE4 interface or on a vlan interface?

elliott-jey Fri, 05/02/2008 - 06:50

>>When you plug the PC into another port does the port report as up

yes it does....

>>Where do you have the IP address configured on the FE4 interface or on a vlan interface?

for FE4, I did not configure anything, this appears to have been pre-configured for from the factory....

the ip address is configured for the FE4 interface.

mlitka Fri, 05/02/2008 - 07:02

You can do this from the command line very easily. Are you familiar with Cisco IOS CLI?

You can enter the following and this should help you:


config t

int fe4

ip address

int vlan1

ip address


Check to see if this works. If it does then save the configuration:

copy run start


You can also probably do this from the SDM by clicking on LAN and setting up your network here. You will probably want to first setup your WAN interface like you want it and the move the private IP addressing to the LAN interface.

elliott-jey Fri, 05/02/2008 - 10:59

I am a bit familiar with the IOS Cli, I have connected via the console port. I bought this router to play and learn.

the commands you have suggested, is to enable FE4 with ip address

currently this is already working. what I would like to achieve for now anyways is this:

make FE4 to connect to a dsl modem (pppoe)

setup a dhcp server and hand out ip via FE0 ~ FE3

configure a very basic firewall between FE4 and the inside protected lan..

somewhere here something with NAT needs to be setup also..

any suggestions?



This Discussion