caller ID issue

Unanswered Question
Apr 30th, 2008

Hi all. I have an issue where a customer has several PRIs and when a internal caller calls out, they get a different caller ID mask, according to which PRI they hit. I have it set on the route pattern (in callmanager 6.x) to use a particular number when it hits that particular route pattern. But, it doesnt seem to work and I always get the same results no matter what. The same 4 numbers come up every time, depending on which of the 4 PRIs you hit. I have tried to call the carrier and they tell me they are not doing call masking at all. But I think they are because I have never seen the numbers that show up. So, I know I didnt program it in. How can I do a test to prove this to the carrier that they are the problem?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Jaime Valencia Wed, 04/30/2008 - 14:10

i'd check the route list config before blaming the telco. route list config overrides any other transformation. also you can hardcode a calling number in the GW config.

if those are clear then do a debug isdn q931 and look at the setup message for the calling and called IEs.

HTH

javalenc

if this helps, please rate

jjoseph01 Wed, 04/30/2008 - 14:19

Thanks for responding, yeah, nothing in the route lists either. Ill do a debug and see what I can find. Thanks for the input, will get back to this tomorrow to update it.

jjoseph01 Thu, 05/01/2008 - 05:39

Hey, did the debug isdn q931 and it shows the number going out as the number I programmed in. But, on my caller ID of the phone Im calling, it still says something different each time, according to which PRI it hits. Is it safe to assume with this test that its the carrier?

Kenneth Mohammed Thu, 05/01/2008 - 05:51

Yes, more than likely it is with the carrier, call them and find out if the outbound caller id is set to broadcast the main billing number of the PRI's in question.

Hope that helped

Actions

This Discussion