Cisco Unity Failover Wizard Fails

Unanswered Question
May 1st, 2008

Anyone any ideas on this one.


I have a cisco unity voicemail only solution with failover with the secondary hosting AD and Exchange 2003.


The same error has occurred twice after a total rebuild.


Scenario


Both servers build ok with identical features and drive locations.


UTIM runs succesfully on both servers.


Failover wizard runs succesfully on the Primary


Failover wizard fails on the secondary



Failed to verify SQL Configuration Table



Detailed information



Method Iavrdbconnection::Execute(KYNUDCSVM002,CSP_ConfigurationCleanupLastModifiedTime) returned [0x80040e37]



CCO is not much help, there are a few things in the general area which are all known bugs with SQL workarounds but not my specific one.


Google comes up with a few 0x80040e37 errors which are related to AD and Exchange which point to the following registry keys missing, but I don't want to go mucking about with that without cisco intervention.



[HKEY_CLASSES_ROOT\LDAPNamespace\Clsid]

@="{228D9A82-C302-11cf-9AA4-00AA004A5691}"


[HKEY_CLASSES_ROOT\LDAP\Clsid]

@="{228D9A81-C302-11cf-9AA4-00AA004A5691}"


I have attached the Failover config log file from both servers

Cheers


Martin



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (7 ratings)
Loading.
mwcodd Thu, 05/01/2008 - 04:38

Hi

Thanks for your response, I am actually running Unity 5.0, so have the latest wizard. I did look at that bug, and it is similar but not the same.


Martin

pjweppner Thu, 05/01/2008 - 04:47

And you're running the same build or later of 5.x as indicated in the bug notes? Run the Gather Unity System Info (GUSI) to verify. It sounds bug related to occur twice after a rebuild.

mwcodd Thu, 05/01/2008 - 05:16

i'm running 5.0(1.0) so shouldn't be seeing that bug. I agree it is probaly bug related, possibly a new one?

Trent Hurt Thu, 05/01/2008 - 05:21

We recently upgraded to Unity 5 and had same problem with the failover wizard not completing on the backup server. We opened a TAC case and the engineer was able to fix with these steps.


1. The engineer added entries for the primary and failover servers to the hosts and LmHosts files on both servers.


2. He then created a unique account for the MSSQLSERVER service and the SQLSERVERAGENT to log on as. He stated that this was just his personal preference. Doing this will stop and start Unity services. (Needs to be member of domain users and also a member of local admins group)


3. He then went into SQL enterprise manager and deleted all SQL server registrations, and then created new SQL server registrations and picked the primary server and then added another for the backup server. He did this on both servers.


4. He then reran the wizard on both servers successfully.


Hope this helps



mwcodd Thu, 05/01/2008 - 06:16

Thanks


Just tried that and still no joy. Were you getting exactly the same error as me or just a general replication error

Trent Hurt Thu, 05/01/2008 - 07:01

This was the error I was getting.


MethodIAvRdbConnection::Initilize(secondaryserver)returned [0x80048807]


I would open a Tac case. Sorry that couldn't be more help.


cuevas Sun, 06/01/2008 - 18:24

I followed all the steps in that Link, and I'm still getting the same errors. Anything else??!!

cuevas Sun, 06/01/2008 - 17:46

Hey Martin,

I'm getting the same exact error, the only difference is the Server names.

I'm running Unity 5.0.1 ES30.


The FCW runs fine on the Primary Server, but on the Secondary Server it fails, and now i can't start Unity Services on the Secondary Server.

dandrools Tue, 08/19/2008 - 11:29

I have run into the exact same problem on a Unity 4.0(3) to Unity 5.0(1) upgrade I am working on. Doing everything in the lab first and this is happening with every attempt.


I have followed the above procedures to try to fix the problem, and have even made the point to do them before ever attempting to run the failover wizard and am still running into it.


Has anyone with this problem had luck getting past it?

rwilkinson Tue, 09/02/2008 - 01:31

Hi,


I exactly the same problem with Unity 5.0.1:-


Failed to verify SQL Confuration table.


DETAILED INFORMATION:


MethodIAvRdbConnection::Execute(LONLDCCCMU02, csp_ConfiurationCleanupLastModifedTime) returned [0x80040e37]:



I logged a support call and they said it was related to Bug ID 'CSCef60341'. Here is how I worked around this issue.


On the primary server open a 'cmd' prompt and execute the following command:


osql -E -d UnityDb -Q "update Configuration set LastModifiedTime=NULL"


Then, Re-run the FailoverConfig wizard on the primary server.


Then, Re-run the FailoverConfig wizard on the Secondary server.


This sequence of events gave me a successful failover configuration on Unity 5.0.1 after 3 days of getting the same error.

smithsera1 Mon, 09/29/2008 - 06:01

super solution, i came across the same problem and issued the command above and the wizard completed on secondary server with no problems.


Cheers

Paul

Tommer Catlin Thu, 12/18/2008 - 18:00

Not sure if the cmd paste worked for me, but I used it anyways. Another 5.x failover not working.


Ran the fix, but then replication was not working. Turns out the Unity DBs in SQL have to be in the exact same location also or it will not work. bah!

jasondrisc Thu, 02/12/2009 - 19:01

rwilkinson,


I received this exact error attempting to complete an upgrade from 4.2(1) to 5.0(1) this evening. The steps in your post resolved the issue. THANK YOU!!


Jason

filiberto.aguirre Sun, 04/26/2009 - 08:15

rwilkinson,


you saved ours lives,


we spent some days without knowing the reason of this error.


we execute the commands and the failover

is working now!!!!!


THANKS A LOT !!!!!



e.parsonage Fri, 09/18/2009 - 03:16

I ran into the same problem on Unity v7.0(2), which would sort of mean this problem is still around even in Unity v7.x

Anyway used the same fix process as above and failover config completed on both servers.


Thanks again Martin for starting this post..........


E

Actions

This Discussion