Auto QOS on 6500 with Sup32-10G gives warning errors

Unanswered Question
May 1st, 2008
User Badges:

We've enabled auto qos on our 6504 w/sup32-10G on our ws-6148a blades and are receiving the following errors. Is this normal? Code is the latest out: 12.2(33)SXH2, switches are runnin as L2 devices only (no routing):


Warning: rcv cosmap will not be applied in hardware.

To modify rcv cosmap in hardware, all of the interfaces below

must be put into 'trust cos' state:

Gi3/1 Gi3/2 Gi3/3 Gi3/4 Gi3/5 Gi3/6 Gi3/7 Gi3/8 Gi3/9 Gi3/10 Gi3/11 Gi3/12 Gi3/13 Gi3/14 Gi3/15 Gi3/16 Gi3/17 Gi3/18 Gi3/19 Gi3/20 Gi3/21 Gi3/22 Gi3/23 Gi3/24 Gi3/25 Gi3/26 Gi3/27 Gi3/28 Gi3/29 Gi3/30 Gi3/31 Gi3/32 Gi3/33 Gi3/34 Gi3/35 Gi3/36 Gi3/37 Gi3/38 Gi3/39 Gi3/40 Gi3/41 Gi3/42 Gi3/43 Gi3/44 Gi3/45 Gi3/46 Gi3/47 Gi3/48

threshold configured on all 48 ports on slot 3.


Should config changes be made to the cos trust to utilize hardware capabilities?


Thanks,


-Scott




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
amritpatek Wed, 05/07/2008 - 06:11
User Badges:
  • Silver, 250 points or more

Use the "Interface Range" command and try to disable it on all the interfaces on the module.


By default, you should not see the "rcv-queue .." configurations under the interface. In order to remove the configuration,

try the following commands.


Interface range Gi1/1 - 1/12

Mls qos trust cos

No rcv-queue cos-map

No mls qos trust cos


swharvey Wed, 05/07/2008 - 07:00
User Badges:

Thanks for the suggestion. Below are the current port configuration for an auto qos port with pc/phone, as well as the commands I tried on a set of selective interfaces (G3/1 -2). I get an error regarding the asic. Since we have phone ports requiring auto qos voip cisco-phone intermixed (non sequential) with access only ports (printers, scanners, etc), this may present a problem on the 6500's.


This problem does not exist on the 4500 series chassis. :-/



interface GigabitEthernet3/1

description Test PC and Phone

switchport

switchport access vlan xx

switchport mode access

switchport voice vlan xy

wrr-queue bandwidth 20 100 200

priority-queue queue-limit 5

wrr-queue queue-limit 65 15 15

wrr-queue random-detect min-threshold 1 70 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 2 70 100 100 100 100 100 100 100

wrr-queue random-detect min-threshold 3 40 40 50 50 60 60 70 70

wrr-queue random-detect max-threshold 1 100 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 2 100 100 100 100 100 100 100 100

wrr-queue random-detect max-threshold 3 70 70 80 80 90 90 100 100

wrr-queue cos-map 2 1 1 2

wrr-queue cos-map 3 5 3 4

wrr-queue cos-map 3 7 6 7

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast


Error message below when int range is attempted on G3/1 -2 (both phone ports):


switch-lab1(config-if-range)#mls qos trust cos

switch-lab1(config-if-range)#no rcv-queue cos-map

Warning: Can't remove cos-map because configuration is used by some other port(s) on this ASIC which has AutoQoS enabled

Warning: Can't remove cos-map because configuration is used by some other port(s) on this ASIC which has AutoQoS enabled




Actions

This Discussion