Matching router & switch L2 settings

Unanswered Question
May 1st, 2008
User Badges:

Hi,


I need to connect a C3825 router who's config. I can't change who's L2 config is,

interface GigabitEthernet0/1

...

duplex full

speed 100

media-type rj45

negotiation auto


to a switch model WS-C3560E-48TD-S.

Is this the correct config. for this switch port,

int gi 0/1

...

switchport access vlan 25

switchport mode access

switchport nonegotiate (No DTP frames being sent ie. no trunking negotiation done)

duplex full

speed 100


Why does the router fix the duplex and speed & still have "negotiation auto" - it seems contradictory.

There's some info on this at,

http://www.cisco.com/en/US/prod/collateral/routers/ps5855/prod_qas0900aecd8016a953.html

- but it doesn't seem to answer this particular question.


Regards, MH


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

This may help:-


"If the speed and duplex setting for g0/0 in SFP mode is speed=1000 and duplex=full, autonegotiation is in forced mode and autonegotation is turned off. For all other mode settings of speed or duplex for SFP, autonegotiation is turned on.


If speed=1000 and duplex=full modes are specified for both g0/0 and g0/1 interfaces in copper mode (RJ-45), autonegotiation is still turned on. This is considered to be in forced mode for speed=1000. This occurence is per the Annex 28D.5 extensions required for clause 40 (1000-BASE-T) IEEE 802.3.


When the speed and duplex modes are forced for 10/100, and full or half modes are forced for g0/0 and g0/1 interfaces, autonegotiation is turned off. If the interfaces are not in forced mode for 10/100 speeds, then autonegotation will be turned on."


HTH.

mohammedmahmoud Fri, 05/02/2008 - 04:28
User Badges:
  • Green, 3000 points or more

Hi,


In another context, in the case of the 7200 VXR with NPE G1 (although i'll double check this for the 3800 series), the auto-negotiation option (via the "negotiation auto" command) is only effective when using the GBIC media, it is used to enable the IEEE 802.1z Gigabit Ethernet (1000 Mbps) auto-negotiation protocol, thus the auto-negotiation feature is not supported when using the rj-45 media type and will be ignored if enabled.


[edit] After double checking, with the 2800 and the 3800 series, the "negotiation auto" is actually different than the G1, and more over it is actually totally removed in newer IOS, i am running 12.4(3g) on a 2821 router and the command is decommissioned, accordingly i advice you to do an IOS upgrade, the main problem here is according to Cisco on the IOS you are operating there are no standards defined for 1000BASE-T (RJ-45) operation without auto-negotiation.


[edit] Another thing that seems to confuse you, the DTP on the switch side, routers doesn't support DTP, thus the DTP configuration has no significance when connecting a switch to a router, in case you needed to configure a switchport connected to a router as a trunk port, you can't use DTP and you have to configure it manually as a trunk.


BR,

Mohammed Mahmoud.

MARK HEUZENROEDER Sun, 05/04/2008 - 04:44
User Badges:

1) So will the switch config. I submitted work with the router config. I submitted?

I think you're saying 'yes' but I'm not sure.


2) Are you saying that the "negotiate auto" config on the router is ignored by the router because I'm using RJ-45 & because duplex=full & speed=100 ?


Thanks, MH


Actions

This Discussion