cnf-files

Unanswered Question
May 2nd, 2008
User Badges:

I'm trying to configure a new CME.

every time i load a firmware to cisco 7960 and try to create a cnf it gives this message:


pbx(config)#tftp-server flash:P00307020200.loads

pbx(config)#tftp-server flash:P00307020200.bin

pbx(config)#tftp-server flash:P00307020200.sbn

pbx(config)#telephony-service

pbx(config-telephony)#load 7960-7940 P00307020200

pbx(config-telephony)#create cnf-files


Post-init cnf creation is in progress, pls re-issue this command later


pbx(config-telephony)#create cnf-files



Any idea how to solve this problem?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
Pari Thiagasundaram Fri, 05/02/2008 - 10:38
User Badges:
  • Silver, 250 points or more

Can you verify IP source address and port are configured? Along with max-dns?


The warning message means that you are trying to modify cnf related CLIs while cnf is under construction. Have you tried the command after the "post-init" process has completed the cnf-file construction ?


It looks like a configuration issue to me.

valides007 Fri, 05/02/2008 - 11:01
User Badges:

well this is what i did.

I already have a running CME. So i copied the configuration from this unit and paste it in the new CME. Everything seems working fine except the CNF creation.


I have tried the command many times. It seems that the post-init is still in process.



Archant IS Thu, 07/10/2008 - 02:34
User Badges:

Did you find a fix for this as i have same situation.

Thanks.

Ayodeji Okanlawon Thu, 07/10/2008 - 03:40
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

I have seen this before. The cme router seems to be stucked in creating the configuration files for the 7960 phones.


If after a while, you still get this prompt, reload the router and you will be fine

Archant IS Fri, 07/11/2008 - 00:02
User Badges:

Hello, ive reloaded several times now, it definately seems stuck. Do you meen wipe and start again?

Thanks

Ayodeji Okanlawon Fri, 07/11/2008 - 00:39
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

can you issue this command on your ccme router...


show telephony-service tftp-bindings


if you hsve configuration files already created for your phones...use the more system command to view the file...


eg if you have a 7960, you should have an output like this from the show telephony-service tftp-bindings


tftp-server system:/its/SEPDEFAULT.cnf

tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf


tftp-server system:/its/XMLDefault7960.cnf.xml alias SEP000DBDBEF372.cnf.xml (this represent mac addy of a phone)


to view this file and its content..use the command


more system:/its/XMLDefault7960.cnf.xml


this will help you to see the configuration files.




Archant IS Fri, 07/11/2008 - 01:45
User Badges:

Hello, show telephony-service tftp-bindings doesnt return anything i'm afarid.

Thanks.

Ayodeji Okanlawon Fri, 07/11/2008 - 02:08
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

That means that the router ha not created any configuration files.


May be you should start all over gain, erasing the files in the flash....this may be a long short..

Archant IS Sat, 07/12/2008 - 10:55
User Badges:

Fixed, didnt have ip source-address ... port 2000 in my telephony-service

Thanks

m_chernogorsky Fri, 08/08/2008 - 11:43
User Badges:

I found solutions.

1. configure max-dn, max-ephone

2. configure time (clock set or ntp)

3. ip source-add port

4. load and create cnf

Maybe not all this step is required, but its work.

Thanks ^-)

MasterRu Tue, 03/20/2012 - 12:08
User Badges:

I had this error and did the following to resolve it:


  1. Create tftp-server commands with alias
    • tftp-server flash:/phone/7940/P00308010200.loads alias P00308010200.loads
    • ..... other tftp-server loads as well, noting the alias
  2. Set tftp-server source address
    • ip tftp source-interface
  3. Put the following commands under telephony-service
    • telephony-service
    • max-ephones
    • max-dn
    • ip source-address
    • cnf-file location flash:
    • load
    • create cnf-files


    After this, you should be able to configure your ephone and ephone-dn and watch the phones register.  If you enable debug ephone registration and debug tftp events, you can watch it all happen.

    Actions

    This Discussion