Extension Mobility

Unanswered Question
May 5th, 2008

I have configured EM for the first time andam getting an error when trying to login : Error: Device does not exist.

I have followed configuration steps carefully and everything I can think of for this to work has been configured.

Anyone know what is causing this error?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
rogermoreau Wed, 05/07/2008 - 06:36

Is there a troubleshooting guide for Extension Mobility using CUCM 6.0? This guide seems to be for Cisco CallManager 3.x or 4.x.


shaunswales Thu, 05/08/2008 - 00:49

There probably is but the fundamentals should be the same, I don't know I have never used CCM 6, only 5.

shaunswales Thu, 05/08/2008 - 03:11

I have checked the URL in the Service Parameters section and it is exactly as described, with obviously the IP address of the CM. Still giving the same error.

[11]-Device Does Not Exist

davidblair Thu, 05/08/2008 - 06:37

I'm having the same problem Shaun. We just upgraded to CM6 and I'm getting the device does not exist error now after selecting the device profile for the user.

I'm currently troubleshooting through it. Will reply back if I find something.

davidblair Thu, 05/08/2008 - 09:03

Alright. Here's what we had to do to get it working:

For every device that will be running extension mobility, we had to enable extension mobility on the phone configuration page in Call Manager (we were able to bulk the setting to all the phones once we figured out this was the problem)

Go to Call Manager's web interface

Select "Device" -> "Phone"

Search for the phone you will be using extension mobility on.

Once you select the phone by clicking on it, you'll be on the phone configuration page.

Scroll about 2/3rds of the way down the page. There will be an "Extension Information" section.

Make sure "Enable Extension Mobility" is checked and you'll probably want the dropdown for the logout profile to be set to "-- Use Current Device Settings --".

Hope this helps.


shaunswales Thu, 05/08/2008 - 23:50


I have already enabled extension mobility on the device configuration page, however, the logout profile drop down when I select use default, it gives me the error, when I try use one I have created it, and save it, Once saved I go and check and it is still sitting on "use default", and I still get the same error. Let me go check everything from scratch and put it up here, maybe i have missed something. I am just testing the EM Service on 1 phone for the time being, ut need to roll it out for the whole branch before end of business today :(

SportsGuy0223 Thu, 10/16/2008 - 10:01

I am running into the same exact issue with UCM 6.1.2 did you find a resolution to your issue?

dual_line Sun, 10/26/2008 - 17:56

I fixed my issue and I'm really kicking myself!!

The service URL was incorrectly formatted. For some reason I added it as:


I discovered my error after collecting EM traces via RTMT. I noticed that after selecting login to EM I was sending 'DEVICENAME' to CUCM instead of the UserID.

From the trace:-

58:Executing Login for device=DEVICENAME


- CMDatabase:getDeviceInfo: Device does not exists: DEVICENAME


This Discussion