Strange QoS problem on 6500 switch

Answered Question
May 5th, 2008
User Badges:

Hello


We have a video conf. unit (10.x.x.3) connected to gig9/2 on a 6500 w/ Sup. 720. Connected to gig1/1 is our MPLS router.


If we monitor 9/2 we see the packets being tagged properly with dscp 46 - which is what we expect.


If we monitor gig1/1 we see that packets are now tagged dscp 0 (default). What gives?


Here's the config:


interface GigabitEthernet9/2

description *** Video unit ***

no ip address

logging event link-status

speed 100

duplex full

mls qos trust extend

mls qos trust cos

switchport

switchport access vlan 15

switchport mode access

power inline never

spanning-tree portfast

service-policy input VIDEO


=============================


interface GigabitEthernet1/1

description *** WAN ***

no ip address

logging event link-status

speed 100

duplex full

wrr-queue cos-map 1 2 2

priority-queue cos-map 1 3 5

mls qos trust dscp

switchport

switchport access vlan 6

switchport mode access

power inline never

spanning-tree portfast


===============================

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos



class-map match-any VIDEO

match access-group name VIDEO


policy-map VIDEO

class VIDEO

set dscp ef


ip access-list extended VIDEO

permit ip any host 10.x.x.3

permit ip host 10.x.x.3 any


===============================


I would've expected the QoS marking to be preserved throughout.


Thanks in advance!!



Correct Answer by schmij01 about 9 years 2 months ago

Your trust statement is screwing up the final DSCP on the packet. Since you are trusting CoS, and it looks like there is no trunking/802.1P value to use, it is setting the internal DSCP to 0. You don't see this until the packet leaves the switch though, since remarking occurs on egress.


See this section and diagram for more info:


http://www.cisco.com/en/US/customer/products/hw/switches/ps700/products_tech_note09186a008014a29f.shtml#summary


So, remove the mls qos trust statements and just let the policy-map do its work and you should see better results.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
schmij01 Mon, 05/05/2008 - 12:27
User Badges:

Your trust statement is screwing up the final DSCP on the packet. Since you are trusting CoS, and it looks like there is no trunking/802.1P value to use, it is setting the internal DSCP to 0. You don't see this until the packet leaves the switch though, since remarking occurs on egress.


See this section and diagram for more info:


http://www.cisco.com/en/US/customer/products/hw/switches/ps700/products_tech_note09186a008014a29f.shtml#summary


So, remove the mls qos trust statements and just let the policy-map do its work and you should see better results.

jkeeffe Wed, 09/21/2011 - 12:24
User Badges:

I just saw this post - How were you monitoring the links to see that packets were getting marked or not?  Were you spanning a port and doing a packet capture, or is the a 6500 command that allows you to see the markings?

Actions

This Discussion