Failed to enable Netflow in Physical Interface

Unanswered Question
May 6th, 2008

Our customer said they failed to enable Netflow on their physical interface but success on vlan. Currently they use 12.2(33)SRB1 image on 7600 series. Is there any suggestion for this issue ?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
yjdabear Tue, 05/06/2008 - 07:36

There's not enough details (module type and configs involved) to go on, but if "physical" means a layer-2 interface, of course that won't work.

Jan Nejman Tue, 05/06/2008 - 07:48


as wrote yjdabear, on 7600 you need to enable netflow on all L3 interfaces (you get the list via: show ip interface brief | exc unassign


and also enable mls nde export:

mls netflow

mls flow ip interface-full

mls nde ...

Don't enable NetFlow on L2 ports...

See more infromation about configuration on the URL:

Kind regards,

Jan Nejman

Caligare, Co.

akusuma1 Tue, 05/06/2008 - 21:26

Hi nejman and yjdabear,

What I mean, physical interface mean physical port (Gi). We are on network monitoring side and configuration handle by different group. They said the configuration : ip route-cache

flow" or "ip flow ingress" only can apply on vlan interface (L2) and not on physical interface. I have read your url configuration and so far I don't see any limitation to enable it on Gi interface. Please correct me ?

Jan Nejman Wed, 05/07/2008 - 00:04


physical port can be configured as switched port (layer 2) or with an IP address (layer 3).

On 7600 you need to enable netflow on all L3 interfaces (no matter if it is VLAN or physical interface, enable netflow on all L3 interfaces). You get the list of these interfaces via command: show ip interface brief | exc unassign


interface Vlan100

interface GigibitEth0/1


You also need enable mls netflow export. mls is running in PFC (supervisor) and 99% of flows is exported from mls cache. See documentation how to enable netflow export from mls.



This Discussion