Problems between a Wireless Controller and a Switch.

Unanswered Question
May 6th, 2008

I have a Wireless Controller 4402 connected to one sw2960G.

I configured the controller with LAG and the switch (sw2960G) with etherchanel.

I connected the controller 2 distribution ports to the 2 ports of the switch (configured with etherchanel).

It worked like it should work.

But the problem is like this: if I take one cable that is connected to the switch and unplugged that cable from the switch (if that cable is the one connected to controllers port one) I have connectivity between both machines.

If I plug in the switch the cable connected to controller port one and take the other cable and unplugged that cable from the switch I stop the connectivity between the two machines.

I think that was not supposed to happen… because the LAG in the controller should put every AP in the second controller's port, and the connectivity between the machines should not end.

Can any one help me?

Can any one tell me what I am doing wrong?

Thanks in advance,

Rui

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ericgarnel Tue, 05/06/2008 - 05:31

How do you have the ap-manager interface port priority setup? and/or do you have more than 1 ap-management enabled interface with the priority alternating ports with the physical interface?

Did you change any of the spanning tree settings on the controller? It is best to leave them to defaults

Also, what type of etherchannel load balancing method are you using?

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094714.shtml

rcapao Tue, 05/06/2008 - 07:10

With LAG enabled in the controller I think I can have only one ap-manager interface.

The LAG will (it is supposed to) do the load balance automatically.

I mean, if one of the interfaces is “down” the other will have to coupe with all the AP's.

I should have always connection between the controller and the switch.

The STP of the controller is configured by default (STP Mode = OFF).

In the case of etherchannel load balance… I saw the Cisco documentation and I did not saw any thing about that. I think that The LAG as to do that for the controller… I'm right about that?

I will see the link that you advised…

Can you help me?

Thanks,

Rui

ericgarnel Tue, 05/06/2008 - 07:55

Hmmm.... I'm not sure about the one ap-mananger interface w/LAG. I have our 4402s configured without lag+etherchannel and use 2 ap-management interfaces and it works fine.

Can you post the switchport config for both the etherchannel port and the physical ports?

rcapao Tue, 05/06/2008 - 11:50

The etherchannel config is:

!

interface Port-channel1

switchport trunk allowed vlan 8,9,99

switchport mode trunk

!

!

interface GigabitEthernet0/21

switchport trunk allowed vlan 8,9,99

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/22

switchport trunk allowed vlan 8,9,99

switchport mode trunk

channel-group 1 mode on

!

I put the load balancing as Cisco advised

port-channel load-balance src-dst-ip

but that don't worked.

Any one can help me?

Thanks,

Rui

rcapao Mon, 05/12/2008 - 14:25

There is some one that can help me?

I need to know if I am doing something wrong.

I forgot something? There is something missing?

Thank,

Rui

jsfsantos Tue, 05/13/2008 - 05:13

I'm with the same problem, so I search about this in cisco's site to find the solve, but not sucess.

I see anything about the version of the WLC that has a bug . 3.2 and the solution is Up grade to 4.2.

I think that is a hardware problem, but i changed the GBics and Chassi WLC and the problem appear again.

With anyone had the same environment so tell the solution.

Thanks,

João Ferreira.

Actions

This Discussion

 

 

Trending Topics - Security & Network