nokia ICC Cisco E61 Phone CCM4.1.3

Answered Question

Having trouble getting the Nokia ICC Cisco software on my E61 to register with CCM. Setup a Wireless connection (LEAP) on the phone and this is working (using Mail for Exchange on phone via wireless which is working). Authentication via ACS SE and can see in the logs connection is OK. Have entered a manual IP (Pub) in TFTP setting under SCCP profile as not using option 150 via DHCP. Have installed the Nokia S60 device type via the .EXE from Nokia website on all CCM's in the cluster and have reload the pub. Have auto registration enabled on CCM. On E61 the SCCP profile states not registered and under the Nokia ICC icon when checking Status it shows no profiles active. Have used previous versions of enterprise call which were Beta versions obtained via Cisco account Team and these have worked in the past. CCM can ping the E61's IP Address. Have also manually added the phone, as S60 device type, in CCM in case of registration issue and still will not connect. Anyone have any suggestions??

Correct Answer by pasimahone about 9 years 1 month ago

Hi,


I'm happy to help you.

Yes you have to delete the device and add it as S60 type.


I believe the guide you are refering is Nokia Eseries Deployment Guide

You cand find it from http://www.businesssoftware.nokia.com/nokia_intellisync_call_connect_for_cisco_downloads.php


-Pasi-

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.2 (5 ratings)
Loading.
agiaccone Tue, 05/06/2008 - 08:36
User Badges:
  • Bronze, 100 points or more

I've successfully configured e65 and e61 on a slighlty different environment. However maybe here

http://snippets101.blogspot.com/2008/01/cisco-and-nokia-dual-mode-for-dummies.html


you could find some useful hints, especially on the second part. (configuring the SCCP Profile and the Internet Telephony service)


HTH,

Alberto


However there is also a Nokia deployment guide (arrived after I did everythig... :-()


http://www.businesssoftware.nokia.com/nokia_intellisync_call_connect_for_cisco/files/Nokia_Deployment_Guide_1_1.pdf


pasimahone Tue, 05/06/2008 - 22:34
User Badges:
  • Bronze, 100 points or more

Hi,


Did you get devices to work?


Br,

-Pasi-

agiaccone Tue, 05/06/2008 - 23:22
User Badges:
  • Bronze, 100 points or more

Everything works for me. I've also implemented the LEAP authentication and I'm now testing the CCKM fast roaming feature.


David:

After having installed the ICC CallConnect, get to Menu->Connectivity->Internet Telephony.

After it displays "No services active", get to Options->Configure new (or something similar, I have no more this option I'm trying to remember).

Then You should find a "Cisco VoIP" Service that should be configured to use the SCCP profile.


HTH,

Alberto

Thanks all for your posts. I deleted the manually added entry in CCM for the E61. I then removed the profile configured under internet telephony (this was set to use the SCCP profile I had created). I then resetup the profile under internet telephony and the phone register almost straight away. It has however registered as a 7970 in CCM even though I installed the Nokia S60 device type package. Anyone else seen this?


The ICC client has a lot more features (call ID for example) than the beta versions of Enterprise Call I have used and is working well. Anyone know where I need to go to obtain a price for a full license for the product (can't see anything in the documentation)?

a.gooding Wed, 05/07/2008 - 09:25
User Badges:
  • Bronze, 100 points or more

guys,


ive registered mine and it received an extension etc from the call manager (ver 5.1.2). i can call the nokia extension from any ip phone, however, when i try to call an extension from the nokia itself, nothing happens. i set the default call typr as Internet but when i make an Internet Call the call does not go through at all.

any ideas? im using the SCCP 60 DAY trial license


thanks in advance


P.S i also noticed that it takes a good while (10-20 mins)after if i go out of range.

pasimahone Wed, 05/07/2008 - 23:00
User Badges:
  • Bronze, 100 points or more

Hi,


So when you try to make a call nothing happens? Even if you type the number and select from options->call->internet call?


Have you created Internet telephone settings?

(menu->tools->settings->connection->Internet tel.)


Is the device in correct Route partition?


You can also send questions regarding ICC client to Nokia's ICC Voice Trial page https://feedback.nokiaforbusiness.com/viewqualification.aspx?id=9 (needs registation)


-Pasi-




a.gooding Thu, 05/08/2008 - 06:30
User Badges:
  • Bronze, 100 points or more

exactly correct. when i try to make the call, it pauses for about 1 second and then goes back as if i just dialed the extension.


im looking at my E65 right now and these are the settings

SCCP settings - TEST- registered

Internet Telephony - CiscoVoIP, SCCP- TEST

Call - Default Call Type - Internet


If an extension calls me it proceeds as normal. if i call he above problem exists. My Partition and CSS are fine, its a lab no complex configuration


Ive also registered this with my CCME lab and the same thing occurs.


Phone firmaware - 1.0633.18.01 - Nokia E65


Ill check out the url you sent as well, thanks for the reply


pasimahone Thu, 05/08/2008 - 22:21
User Badges:
  • Bronze, 100 points or more

Hi,


I can see that you posted your problem to Nokia's Trial page also.


Could you check this:

It sounds like you have activated "Automatic redialing" (Settings -> Phone -> Call -> Automatic redial).



-Pasi-



a.gooding Thu, 05/08/2008 - 23:27
User Badges:
  • Bronze, 100 points or more

Just got a reply from Nokia with your same suggestion. That was it, everything is working properly now.


thanks a mil here is a rating to match your reply


thanks once again

pasimahone Wed, 05/07/2008 - 22:40
User Badges:
  • Bronze, 100 points or more

Hi David,


ICC client will always try to register first as Cisco 7970 type. If you configure device as Nokia S60 type, it will then register as Nokia S60.


You can find the price from Cisco partners.

Product code for CUCM is NOK-SCCP-CCM-01

and for CME/UC500 NOK-SCCP-CME-01

If you google that code you will find the price :)


-Pasi-



-Pasi-


Many thanks for the information. Very helpful. I'll have a play with the ICC setup on CCM later and see if I can get it to register as an S60. I guess I delete the device and then add it manually (did this in the first instance but didn't work, see OP). I remember seeing something int he ICC 1.0 to 1.1 upgrade guides that you can delete the device and setup again so will dig that document out and follow it.


Thanks also for the part codes. 5 point on there way.


D

Actions

This Discussion