CTI Agent desktop goes to reserved after agent logs in

Unanswered Question
May 6th, 2008

Hey,

I have a little problem that keeps comming up now and then in my CC.I am running Hosted edition.On some Ext. when agents login to cti agent desktop,the agent is immediately taken to reserved state once they click on ready button.Calls are routed to this agent but being in reserved state..the cti then logs out the agent after some time.

What could really be the cause of this? and how do I resolve it permanently?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mesumbeslin Tue, 05/06/2008 - 23:35

Hi,

They are all associated.I thought without the ICM user association the agent can't even login to the CTI agent.The agents can login OK..but they are put in the 'reserved state'.

david.macias Wed, 05/07/2008 - 03:08

Then the next most common step is to check that the callmanager and ensure that everything is in the right calling search space and/or partition.

david

mesumbeslin Wed, 05/07/2008 - 04:12

They are all in the right partition and CSS.That was the first thing I checked when I got the problem.And I've rechecked.

mesumbeslin Thu, 05/08/2008 - 12:08

It will be hard for me to be given a downtime slot...but when I get it,I'll let you know what happened thereafter.

Thanks for the help

asafayan Wed, 05/07/2008 - 14:51

Hi,

I have the exact same problem. It started occuring on a new call center I just built. We're running 4.05SR2.

The same exact symptoms. This sounds like a bug to me!!!

Thanks,

Amir

ideastoaction Fri, 05/09/2008 - 10:44

I'm getting this exact same problem as well on a sporadic basis. I too am running IPCCx 4.05SR2. Just started happening when I upgraded to 4.05SR2 also. I agree it very well could be a bug.

asafayan Fri, 05/09/2008 - 11:49

I'm opening up a TAC case right now and will update the forum with the results of the case.

Amir

asafayan Fri, 05/09/2008 - 13:05

Refining this issue a little more closely:

With multiple calls in queue, the agent is placed into a ready state. Agent immediately goes into a reserved state.

With reactive debugging, I can see that the contact is getting moved correctly into the Queue logic of my script.

I'm attaching a jpg image of that portion of the script. Can anyone please review it and see if they can find anything wrong with it???

TIA,

Amir

Attachment: 
asafayan Fri, 05/09/2008 - 13:40

Ok - my issue is resolved and I hope that I can helps others - I had Delay 60 Second objects in my Queue with Interuptible "NO" selected.

The script would put the contact into a MOH pattern for 60 seconds, then an agent would go ready, but because the Delay Parameter was set to "No" interupt, the agent would never receive the call.

Interesting thing is that the agent was being placed in a "reserved" state but the ringtone and call were blocked and never passed to the agent.

Good luck!

Amir

mesumbeslin Mon, 05/19/2008 - 21:48

Hi guys...I noticed there are particular PCs and phones where this problem occurs.The solutions given still don't work for me.Any other ideas are welcomed.

Sleen

jason.4.william... Fri, 06/20/2008 - 06:24

This occurs when there is a particular problem delivering a call to the agent. The call flow is this.

1. Agent Becomes Ready

2. ICM Sends a message to the PG to Reserve Agent

3. ICM Send label to the routing client

4. Call Delivered to the agent

If the agent stay's in the reserved state then step 4 is failing this can be for many reasons, Calling search spaces, check the IPIVR CSS/Partitions to ensure it can call the agent extension. Ensure any announcements are set to interuptable, If you are using device targets to deliver calls to the agents, check you have a label for the routing client and that it is correct. The calls that fail will be recorded in the Termination_Call_Detail with a CallDisposition of 1 see if you can find any common elements.

Abdulbaseer Mohammed Sun, 06/22/2008 - 02:28

This is common problem however has different causes. The bottom line is an agent may or may not be available or cannot accept the call either call is not presented or he has too short of time so on....

All these cause agent to be put on reseved state so that next call is not offered. Try debugging your script step by step. Also check your group and agent settings for ansewering the calls.

onlict001 Tue, 07/01/2008 - 13:56

Hi,

i've a similar problem with IPCC enterprise outbound option. When an agent to be reserved for a PersonalCallback call, he go into reserved state and stay here without a real call to do. After the CTI popup an error messege and the agent will be put into not ready state.

This happens only when a personal callback call is attemped to the agent.

thanks in advance for your support.

David

kre8or2007 Mon, 06/23/2008 - 07:22

Check to see if any other agents have logged in to that agent's extension

mesumbeslin Wed, 06/25/2008 - 23:26

Thanks for the replies.I noticed that when I change the IPphone,configure the new IP phone to use same DN,agents are no longer put in the reserve state. Otherwise,the settings for the old IP phone that puts agents to reserve state looks fine.

That's what I can't understand

bullett Wed, 07/02/2008 - 03:44

I also have a similar problem.

The exact scenario is as follows

1. Agent logs in and goes to ready. IF a call is in queue it will be presented.

2. Internal call is made to same skill group as above and call queues. Hang the call up. Make agent available.

3. The agent goes reserved as the call does not appear to have been 'dropped' by the router and it is a phantom call.

4. The agent will remain in reserved for the default time (30s) but no call will be delivered because it has dropped.

5. External calls are correctly removed from queue when they drop in queue.

This is on IPCC 7.2 with IPIVR 4.1 and CAD.

Can you test this scenario and advise if you get the same results.

I have an open TAC on this and will update when I have more info.

simon.thompson Thu, 09/11/2008 - 02:48

I have exactly the same issue, change the phone and it works. Did anyone find fix for this

mesumbeslin Thu, 09/11/2008 - 03:31

Hi,

The problem lies with the device target!Both the NAM and CICM should have a device target entry with HIPCC.You may check and the device target exists,delete and recreate.If possible,delete the device from CCM,re-add it,re-associate it to the ICM user and then add the device target to both the NAM and CICM.

That worked for me.

mesumbeslin Thu, 09/11/2008 - 06:11

I can't exactly tell if it is a bug.for three devices,there existed device targets,but the prob had persisted.For the rest,there was no device target on the NAM,but there existed device targets on the CICM.For those I added,it worked,for the three,I deleted and re-added.

Maybe it's a bug,I don't know,but now,everytime I get the problem,I go through the proceedure i gave and all gets fixed.

Actions

This Discussion