Removing community string in cat OS

Unanswered Question
May 6th, 2008

Having hard time to remove community string in cat OS. Document says

clear snmp community will do it but i don't think it is the case

my config is as follows

set snmp community read-only mycommunity1

set snmp community read-write mycommunity2

set snmp community read-write-all mycommunity3

when i try to remove it

Cat OS switch> (enable) clear snmp ?

access Clear SNMP access table

access-list Clear SNMP access list

community Clear SNMP community table

community-ext Clear SNMP additional community string

group Clear SNMP group

ifalias Clear SNMP ifalias

notify Clear SNMP notify table

targetaddr Clear SNMP targetaddr table

targetparams Clear SNMP target parameters table

trap Clear SNMP trap receivers

user Clear SNMP user

view Clear SNMP view

Cat OS switch> (enable) clear snmp community ?

index Snmp community index keyword

Cat OS switch> (enable) clear snmp community-ext ?

<community_string> community string

Cat OS switch> (enable) clear snmp community-ext mycommunity1

Community string community1 not found. I treid with the other 2 and got the same error, anyone know what i could be doing wrong?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 05/06/2008 - 09:39

The command you want is:

clear snmp community mycommunity1

The clear snmp community-ext is for clearing the extended community string list.

nawas Tue, 05/06/2008 - 10:28

No, clear snmp community command actully ask for a snmp index, see below

switch> (enable) clear snmp community ?

index Snmp community index keyword

I was able to fingure out and it worked using the following command where you type the set command but no community string in it.

switch> (enable) set snmp community read-only

SNMP read-only community string cleared.

Actions

This Discussion