How to add a disclaimer on only outbound messages

Unanswered Question
May 6th, 2008

Newbe to the Iron Port device and I have a question I hope someone can point me in a direction to resolve.

I have tried using the text resources to add the disclaimer, but it added it to both inbound and outbound messages. Thnx

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kluu_ironport Tue, 05/06/2008 - 19:48

If you only have one listener:


If you are seeing the footer being stamped on both the inbound and outbound traffic, this usually means there is only one listener for both inbound/outbound direction. Since the listener is handling both inbound and outbound traffic, applying the footer here may not be something you want.

Workaround:

1. Disable footer stamping on the listener. [network > listener]

2. Enable via an outgoing content filter


------------

Also, this kb article may help.

How do I stamp a footer / disclaimer on email messages leaving my network ... ?

http://tinyurl.com/ezzqf


Newbe to the Iron Port device and I have a question I hope someone can point me in a direction to resolve.

I have tried using the text resources to add the disclaimer, but it added it to both inbound and outbound messages. Thnx
hrd2fnd_ironport Tue, 05/06/2008 - 20:10

I have tried as you suggested and still no disclaimer on outbound messages.

1. Disable footer stamping on the listener. [network > listener] Disclaimer None above and None below.

2. Enable via an outgoing content filter. Created Outbound content action

add-footer("Disclaimer")

kluu_ironport Tue, 05/06/2008 - 20:12

How many listeners and what are their names? [network > listeners]

Are footers enabled on those listeners?

If they're not enabled on the listeners, then you must be applying footers with either msg filters or content filters.

hrd2fnd_ironport Tue, 05/06/2008 - 20:27

How many listeners and what are their names? [network > listeners]
1 listener

Are footers enabled on those listeners?
No
If they're not enabled on the listeners, then you must be applying footers with either msg filters or content filters.
Applied message to outbound content filter.
Still nothing

kluu_ironport Tue, 05/06/2008 - 20:47

If footers/disclaimers are being applied by the "outgoing content filters", then it should not be impacting the Incoming Mail Policy.

Mail that goes through the Relaylist/relayed is applied to the Outgoing mail policy. Anything that is not in the Sendergroup relaylist/relayed, will be assigned the "Incoming mail policy"

Sounds like you should click on the "incoming mail policy", then click on the content filter for the Default policy there. Make sure there is no disclaimer/footer being added by an incoming content filter.


How many listeners and what are their names? [network > listeners] 
1 listener

Are footers enabled on those listeners?
No
If they're not enabled on the listeners, then you must be applying footers with either msg filters or content filters.
Applied message to outbound content filter.
Still nothing
hrd2fnd_ironport Tue, 05/06/2008 - 21:14

Ok, I no longer have a disclaimer on my inbound messages, but now I also have no disclaimer on my outbound messages.

Settings are as so.

. Disable footer stamping on the listener. [network > listener] Disclaimer None above and None below.

2. Enable via an outgoing content filter. Created Outbound content action

add-footer("Disclaimer")

Note that the host serving out the message is in the Relylist

kluu_ironport Tue, 05/06/2008 - 22:28

Now all you have to do is go to "mail policies > outgoing mail policy". Click on the content filter link for the Default policy and enable the Disclaimer footer action.

Ok, I no longer have a disclaimer on my inbound messages, but now I also have no disclaimer on my outbound messages.

Settings are as so.

. Disable footer stamping on the listener. [network > listener] Disclaimer None above and None below.

2. Enable via an outgoing content filter. Created Outbound content action

add-footer("Disclaimer")

Note that the host serving out the message is in the Relylist
hrd2fnd_ironport Tue, 05/06/2008 - 22:33

That was it.

Thanks for all your help. Sooner or later I will get the hang of this product.

I'm going to use this thread to ask something related to disclamers.

I can add a disclaimer without problems. If the message comes back and I reply the footer is added again. I read that I can put an If/Else statement to avoid that behavoir. But honestly I have looked around the GUI and CLI and I'm not sure were I can create a filter with that code inside.

If someone could point me in the right direction I will appriciate it much.

Thanks for your time.

Sorry if I made mistakes, english is not my native language.

kluu_ironport Wed, 05/14/2008 - 23:19

This kb article may help. It may not be external yet. I will have it published soon.


How do I stop adding a footer if there has been one already added to the email thread ?

You have the option of footer stamping every outgoing message. Sometimes you do not want to add a footer every time you respond to somebody's email. This can be accomplished by writing a simple message filter that will look for the text being inserted in outgoing messages and based on the results, it will skip or add the footer. Also, make sure you have a footer already created using 'textconfig' command.

message filter that will achieve the desired result:

Check_for_existing_disclaimer:

if (recv-listener == 'OutboundMail' AND (body-contains('text to search'))

{ deliver();}

else

{add-footer('disclaimer'); }


Replace 'disclaimer' with the name of the footer that you used during the textconfig command. This filter will search every outgoing mail looking to see if the footer has already been added and if not, it will add one to the outgoing message.

Also, make sure this new message filter is above the message filter that currently does your disclaimer.


I'm going to use this thread to ask something related to disclamers.

I can add a disclaimer without problems. If the message comes back and I reply the footer is added again. I read that I can put an If/Else statement to avoid that behavoir. But honestly I have looked around the GUI and CLI and I'm not sure were I can create a filter with that code inside.

If someone could point me in the right direction I will appriciate it much.

Thanks for your time.

Sorry if I made mistakes, english is not my native language.
kluu_ironport Thu, 05/15/2008 - 20:07

Great post Pat.

Something I wanted to add was the distinction between message filters(CLI) and content filters(GUI) and when to use which one.

Differences:

1. Message filters occur earlier in the email pipeline than content filters. Message filters before the email goes into the workqueue. The content filters occur inside the workqueue. See the "Email pipepline" reference link at the bottom.

2. Message filters are currently only administered from the command line. Content filters can be administered from both the CLI and the GUI interface, however, the GUI interface is the recommended mehtod.

3. Content filters have an inbound and an outbound set of content filters, depending upon the direction of the message. That is, whether it's a relayed email (outgoing content filters) or inbound mail(inbound content filters). Message filters on the other hand, are autmoatically applied to both inbound and outgoing traffic, unless you lock it down to a specific listener. If you only have one listener, you may need to differentiate your flow of traffic by sendergroups or something else.

4. Message filters and content filters can pretty much have the same conditions and actions. However, message filters allow for if-else conditions, so they are more robust.

5. You can use message and content filters in unison. For example, use a message filter to insert a custom header that you content filter can key off of. However, this does not work the other way around. You cannot insert a custom header in the content filter and have the message filter key off of that info. Due to the way the email pipeline is set up, message filters come first, then content filters.

6. Easy of use: content filters are a bit more intuitive and user-friendly. message filters are more advanced, so it has a bigger learning curve.

I was able to create the message filter without troubles using the if/else statement.

But the same thing happened after I replied the footer was added to my reply as well.

I removed the footer from the listener. There are no content filters at the moment.

The message filter is working because it adds the disclaimer. But it doesn't avoid duplicating it.

I tought, maybe since the message filter checks all messages its adding it after the message arrives from the inbound mail interface(data2).

But that should not be true, because in the if statement the 'recv-listener' specifies the listener.

I use Data 1 for outbound and 2 for inbound.

I'm lost :!: :D.

Actions

This Discussion