WLC and Siemens WL2 IP phone

Unanswered Question
May 7th, 2008

Hi, our customer would like use Siemens IP Phone WL2 and a Cisco Wireless Controller.

Does have anybody experience in that solution?

Are there other configuration parameter in the WLC necessary as in a pure Cisco WLAN?

We will use a 4400 WLC and software version 4.2.99.

Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alexsandro Reimann Wed, 06/04/2008 - 04:06

Hi, I'm doing an implementation with Cisco WLC 4402 with APs 1130AG and the phone system at my costumer its Siemens Hipath 8000 with OptiPoint WL2 mobile phones. WLC it's in the last system software availiable at Cisco site, so the WL2 in the last version too. The only wireless config style that WL2 works was with a open wireless network with no broadcast at the SSID. The security and encryption configs at WL2 doesn't work correctly with Cisco. This installation wasn't over, so if I get some news, I'll tell you!

Best regards!

Alexsandro Reimann

ricardo.lopes Tue, 12/14/2010 - 05:19

Hello Alexsandro

I'm wondering if you have fixed this interoperability issue. I'm having the same problem. In fact it's working with the encription and no ssid broadcast, but there is a several call connectivity issues. I tried to upgrade the WL2 firmware to the lastest versions (R3) but with that I cannot authenticate with the 1130 AP's. But if I connect to another standalone AP, for example a linksys wrt54gc i can autheticate with the same wirelss settings. The current firmware used and working is 50.2.52 for the WL2. The new ones don't authenticate.

Kind Regards

Ricardo Lopes

Alexsandro Reimann Tue, 12/14/2010 - 05:51

Hi Ricardo,

When I used the solution, only worked in WEP. But  in 2008, Siemens had released an update for wireless phones that  supported the feature of WPA, then the final configuration was WPA-PSK. The support issue was on the phone from Siemens. Which type of authentication are you trying?

BR,

Alexsandro Reimann.

ricardo.lopes Wed, 12/29/2010 - 02:11

Hi Alexsandro,

Sorry for the late reply the authentication used is WPA - Personal (TKIP). The WL2 are working with HFA protocol, The fact is that they woked with 50.002.27 version, and i upgraded it to 50.002.52. They are working with the Cisco's AP's but the fact is that many calll experiencig failures even if the WL2 is directly bellow the AP. With more newer firmware releases I can't get authentication on the cisco AP's (1130), there is no wirelless power even avaiable on the WL2, but as i said if I set the same authentication settings on my linksys wrt54gc i get authenticantion ok.

I need to open a ticket with siemens to troubleshoot this. The PBX is a HIPATH 4000.

Kind Regards

Ricardo

Alexsandro Reimann Mon, 01/17/2011 - 08:54

Hi Ricardo,

    Have you openned the ticket with Siemens? Still having problem with WL2? Hope I could help you in this case.

Please rate if yes.

Best regards!

mlieber Tue, 01/18/2011 - 01:22

Hi all,

we had a lot of problems with the Siemens WL2 solution. Radius authentication doesn't work fine, so we changed to WEP, but this wasn't the final solution because the customer didn't wanted WEP. And there were some other issues.

So we had changed to Cisco phones 7921.

The first tests had shown us that the Cisco phones work very much better. The roaming was better, the radio reception was better and we could you use EAP.

And the last point was: When 3 Siemens phones were associated on one AP the the users took a call, the quality felt down.

There were interruptions in the voice calls and very bad comminucation. This problem we didn't had with Cisco 7921.

So we changed completely to Cisco .

We had done the change in November 2008 and it works very well.

Regards

Martin

rtop00001 Sun, 12/28/2014 - 00:44

Hi Ricardo! Hope you are still following this thread.

I have a Siemens optipoint wl2 professional and try to set it up with my very basic home stand alone password protected access point. It seems I cannot find the right combination in the wlan settings to get access to my network.

I have a profile with WPA - TKIP and EAP type set to LEAP. But then I need to specify a username and a password?? Why do I need to fill in a username? On my access point I only configure a password?

If you can help me out, please!

 

Thanks in advance,

Ronald

Scott Fella Sun, 12/28/2014 - 08:29

You need to specify WPA/TKIP PSK. Don't use any EAP types or else you do need to specify a username and password. 

-Scott

rtop00001 Sun, 01/04/2015 - 23:57

Hi Scot,

I specified all that but to no avail. My access points are all WPA2, can that be the issue?

Grtz,

Ronald

Scott Fella Mon, 01/05/2015 - 04:20

Don't specify all. Just specify WPA/TKIP. This means that WPA2 will be unchecked and AES will be unchecked. 

-Scott

rtop00001 Mon, 01/05/2015 - 13:35

Hi Scott,

 

I don't have any Cisco AP's, just the SoHo SDL modems, which only support WPA2. I cannot specify anything in the phone, only WPA/TKIP and that doesn;t seem to work, altough I can select and see the SSID from the phone.

 

Does the phone itself support WPA2 or only WPA and might that be the case why it's not working with me standard DSL modem?

 

Best regards and thanks for your time,

 

Ronald

Scott Fella Mon, 01/05/2015 - 13:41

That can be the case. If your devices only support WPA and you can only configure WPA2, then those devices will not connect. 

-Scott

mlieber Mon, 01/05/2015 - 21:53

Hi,

I think that's correct.

WL2 supports WPA and WEP, but no WPA2

and please uncheck LEAP authentication, use WPA/TKIP and Pre-Sharedkey (PSK).

regards

Martin

rtop00001 Tue, 01/06/2015 - 05:25

Hi Martin and Scott,

Will WL2 support WPA2 with new firmware orso? All AP's nowadays only serve WPA2, even the public ones. I mean, even the portable WiFi hotspot on my iPhone 5 and Sony Experia are WPA2 only. You cannot change that.

I unchecked LEAP and only have WPA/TKIP and Pre-shared key in my phones WLAN profile.

So I guess the reason I cannot get it online is that the phone only supports WPA and not WPA2? If so and if new firmware is not a solution, I have to buy something else. Any idea what would be a good WPA2 enabled alternative?

BR,

Ronald

Actions

This Discussion