New to This

Unanswered Question

I recently purchased a 7940 VoIP phone with plans to use it for my business. I run my business out of my home. I use Comcast VoIP service and would like to know how to set it up.

I have hooked the phone up and it booted up ans is cycling through some commands. It is apparently looking for an XML config file that I dont have.

Any help with this would be greatly appreciated.

as an FYI I am not very savy in this area>

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dezoconnor Wed, 05/07/2008 - 07:12

When you power up a cisco IP phone it looks for its TFTP server (which will either be a Cisco CallManager or CallManager Express) from which it can download its configuration files. I'm assuming in this case you have neither?

I'm not familiar with Comcast VoIP service, did they tell you to purchase a cisco phone?

HTH

They told me that it would work. Before I worked out of my home I used the same phone and really liked it, so while setting up my VoIP service I asked if the phone would work and they said it should not be an issue. They had them on thier desk in the office so I thought it would be a no brainer.

I dont have the Call Manager or the CM Express. Will another TFTP server work, or how can I get the simple verson of the Cisco CM?

dezoconnor Wed, 05/07/2008 - 07:31

Hi Timothy, I've just been looking at their website and as far as I can tell the Cisco phone isn't going to work with the service you've bought. Any simple digital phone should work though.

For a basic CM or CME you'd be looking at $100's - $1000's which for a simple home office solution for one person would be quite expensive.

dezoconnor Wed, 05/07/2008 - 07:41

ok, no probs. Where were you using the old Cisco phone previously, in another office, another company? Are you a remote/homeworker? Do you connect into the main office via a vpn, hence why you're trying to use the Cisco phone at home?

jarmitage Wed, 05/07/2008 - 15:14

Hi,

You may be able to get your phone working with Comcast, however it's possibly too technical a process for your comfort level.

It sounds as though your phone is using a protocol called SCCP (aka "Skinny"), and you need to be using the SIP protocol for Comcast service. There is a conversion process to arrange this.

Read the links below, and assess if it's something you're willing to try.

Honestly, although the terminology is a little technical, the process is fairly straightforward. People in the forums are really helpful, so don't be afraid to ask!

Converting a Cisco 7940/7960 CallManager Phone to a SIP Phone and the Reverse Process

http://www.cisco.com/en/US/products/hw/phones/ps379/products_tech_note09186a0080094584.shtml

Setup SiP on 7940

http://www.voip-info.org/wiki-Setup+SiP+on+7940+-+7960

Cisco 7940/7960 SIP with BroadVoice (not exactly your situation, but very similar)

http://www.voip-info.org/wiki/view/Cisco+7940%252F7960+SIP+with+BroadVoice

Cheers,

-James.

James,

Ok, Ive downloaded a TFTP server called Solarwinds. (Images attached) I installed it onto my workstation. Within the root directory I have put the following files.

OS79XX.TXT

POS3-08-2-00.loads

POS3-08-2-00.sb2

POS3-08-2-00.bin

POS3-08-2-00.sbn

SIPmac_address.cnf

SIPDefault.cnf

I have updated the *.cnf file to reflect the current build image with the dashes (is that correct? eg. POS3-08-2-00. Or, do I remove the dashes? I know on the txt file the dashes should be there according to the Cisco website.

I then unplugged the phone and plugged it in. The phone does recognize the standard IP 192.168.1.1 for the TFTP and DHCP server, but when I start the server for solarwinds it states the address is 192.168.1.100. Does the trailing zeros mean anything?

Then whey I try to unlock the phone using **# it only unlocks it for a 20 secs or so then relocks. In addition even though it is not locked I can not edit anything. When I push the softkey button to "edit" it tells me "The Key is not active here".

As an FYI the comcast technitian informed me that i need to select the DHCP option while setting the phone up. So Im wondering if I send the update via the TFTP server, however once that is completed I go back and select the DHCP option.

Your right that the verbage in the tech notes are very hard for me to understand. Although I have given it a good effort.

Also, the config file I got were from the internet. In notepad they looked very messy. Not as clean as the examples on the Cisco website. Do you know where I can get clean copies of the default config files? Cisco should make these available in addition to the firmware that I downloaded and it appears they are not, but I could be missing them somewhere.

Any help would be great.

Timothy

Attachment: 
jarmitage Thu, 05/08/2008 - 08:14

Hi Timothy,

It looks like you're off to a good start, I think you should be able to get your 7940 working.

I'm not familiar with Solarwinds (I typically use a similar program called tftpd32, there's a link at the bottom of this post), however the process should be similar.

In your post above, while listing the files you have you wrote "SIPmac_address.cnf". A MAC address is a unique identifier for a network device, so rather than writing the literal term "mac_address" you need the identifier from your phone. To get this address:

Flip your phone over. There are 4 small white stickers with barcodes on the back. The sticker second from the right will have a code that looks like "0123456789AB". It should also have the word "Mac" stamped into the plastic just above and to the right of the sticker.

Once you've got the address, rename the conf file to "SIP0123456789AB.cnf" (substituting your MAC for the example I used).

Now:

Run your tftp program, and enable the DHCP server in the settings. Be sure to provide option 150 in DHCP (that's what the phone is looking for).

Like I said above, I'm not familiar with Solarwinds, however you should be able to change its settings so that it broadcasts its IP address as 192.168.1.1 rather than 192.168.1.100 -- it may seem like a small difference, but the trailing zeros change everything when it comes to IP addresses.

Place your phone's firmware files in the tftp directory.

Connect the phone to the computer (with the phone powered off) one of two ways:

1. Directly to the Ethernet card in your computer using a crossover cable. This is not a standard ethernet cable, and it won't work with a regular one.

or:

2. Through a hub (no crossover cables required), with no other DHCP server connected in this configuration. (ie: Computer -> hub -> phone, no cable modem or DSL modem attached). If you're using a router (D-Link, Linksys, etc), it probably has a DHCP server running already. The distinction is important, let me know if you're stuck on this.

Plug in your phone, and immediately hold the # key while it powers up. When you see the screen prompt about the "reset sequence", enter your reset sequence.

It's probably "123456789*0#", if not then try "3491672850*#".

Once the phone is connected to the tftp program you should be able to monitor what's going on in the "Log Viewer" tab of your tftp program.

Hopefully at this point you will see that phone transferring the firmware files.

If this is the case, allow the transfer to finish and then reboot your phone. You no longer require the direct connection I described above.

The final step is to enter your network settings. That part is described in the last link below.

Links:

tftpd32:

http://tftpd32.jounin.net/

Wireshark:

http://www.wireshark.org/

Manually Configure the Phone Network Settings:

http://www.cisco.com/en/US/products/hw/phones/ps379/products_tech_note09186a0080094584.shtml#topic1a

Hope that helps, good luck!

-James.

jarmitage Thu, 05/08/2008 - 08:19

Hi Timothy,

See my post above for a more detailed response. However, the "P00" part of the firmware you're running indicates that the phone is configured as SCCP for sure, rather than SIP.

Just as background info:

In a typical environment (many VoIP phones in an office), the cnf files are loaded from a central server each time the phone is powered up. This makes it a lot easier for an admin to manage many phones at once, just by cycling their power, rather than changing settings one by one.

In your case we're trying to manually enter the cnf details into the phone, no central server required (after the first setup).

Cheers,

-James.

James,

I have since removed the Solar winds and am using the one you use so its easier to help me :-).

I have attached some screen shots of what I see when I open it. (this is with the network connected and unconnected) attachment "error".

The front page is what I have, not sure what Im supposed to put in there with the exception of the TFTP root directory location.

The settings page there is alot to configure. Some help would be great.

Heres what I did (still to no avail)

- installed new TFTP server.

- changed the root directory to the correct location after opening the tftp server. (got error on open)

- unhooked pc from network and hooked the phone to the computer via a hub. I have a netgear hub so does that have an IP too. It says HUB so I was hoping that would work.

-plugged in phone. (lights on hub lit up so I know it was sending and receiving)

- while the phone powered up I held in the # button and after waiing for 30 secs (phone did nothing) I released, then the phone asked for reset sequence. I typed the 123456789*0# and it asked me if I would like to Initiate Reset Sequence 1=yes 2=no. I pushed 1. It said initializing factory reset and then nothing happened in the log on the tftp.

I did this all again, trying the 2=no option and it didi the same thing.

I also looked for the "option 150" in the tftp program and could not find anything that resembles that. Is this something that you set in the phone?

Am i getting closer?? I know Im probably annoying you with my troubles that must be so easy for you. I really do appreciate the help a great deal!!

tmb

Attachment: 
jarmitage Thu, 05/08/2008 - 15:31

Hi Timothy,

Ok, I've found a step-by-step approach, and modified it for you to help you through the rough patches:

•Turn off your Cisco phone.

•Create a directory on your C: drive by the name of \TFTPD-Root. (You've already done this, I think).

•Put all your Cisco phone firmware and config files into C:\TFTPD-Root (I don't know if you've done this).

•Connect your phone to your PC through a hub, or directly with a crossover cable.

•On your Windows box, assign a static IP address to your Windows box. You accomplish this by altering your TCP/IP properties of your network interface card.

To get to these properties(in Windows XP): go to Control Panel > Network Connections > Click once on "Local Area Connection" > Select "Change settings of this connection" from the "Network Tasks" pane on the left side of the window.

Select "Internet Protocol(TCP/IP)" from the list, then click on "Properties".

If you already have settings in there, write them down - you'll need them once you're done. However you're probably set up with "Obtain an IP address automatically".

In the "Use the following IP address" I would suggest an IP address of 192.168.1.10, subnet mask of 255.255.255.0, leave the gateway blank. Click "Ok", then "Ok" again.

•Start the TFTPD32 program.

•In the TFTPD32 program, click on the "Settings" button:

•For Base Directory, input into the text input box: C:\TFTPD-Root.

•Ensure that "TFTP Server" and "DHCP Server" checkboxes are selected. (You don't need the "Client" box checked.)

•TFTP Security should be set to "None".

•For "Advanced TFTP Options", ensure that "Translate Unix file names" and "Allow '\' As virtual root" are selected. You'll find these checkboxes by clicking the "Settings" button and looking at the lower third of the configuration screen.

•Click the "OK" to save the settings.

•Exit TFTPD32 and restart it so it will use your new settings.

•Turn on your Cisco Phone (making sure it is connected to your Windows machine running the TFTPD32 program via crossover cable or through the hub).

At this stage, your Cisco Phone should start requesting an IP address via DHCP. Your Windows machine running TFTPD32 will answer the request - this is why you can't have any other router in the setup configuration, the phone won't know which one to choose.

Next, it should start to TFTP down all the firmware and configs from your Windows machine running the TFTPD32 program. Your "Tftp Server" window of the TFTPD32 program should start listing all the files the Cisco phone is grabbing.

If anything does not work at this point, please copy whatever you see in the "Tftp Server" window and the "Log viewer" window -- that information helps a lot.

You can now exit the TFTPD32 program, and reverse the changes to the properties of your network interface card that you made.

Hopefully that gets you to the right place. If anything doesn't work the server window information and log viewer information should be able to help!

From there, you'll need to configure your Comcast service, but that's very easy compared to this process!

Cheers,

-James.

Paolo Bevilacqua Thu, 05/08/2008 - 15:38

Great guide, but it is missing the important step of setting option 150 to pc address in dhcp server pool setting.

James and p.bevilacqua,

I was able to get a connection as described in your AWESOME instruction. One thing that I did have to do different is...

Option 150 did not work for me. I read somewhere that Option 66 was another one and on a whim I set option 66 and plugged the phone in and BOOM, i got a connection and it uploaded some stuff. However I did get an error during the upload. (I have attached the log file as you requested.)

I did notice the log was asking for "XMLDefault.cnf.xml" a file that maybe needs to be in the tftp root folder? In any case I am attaching my *.cnf files as they may help, or may be wrong. I noticed they were quite different from the example on the Cisco instruction sheet. Some insight in that would be helpfull.

Thanks again for everything guys. I feel I am right there and your help is more appreciated than you know.

FYI - I renamed my mac_address cnf file. I did not want to have my address on the web.:-)

Regards,

Timothy

Attachment: 
jarmitage Fri, 05/09/2008 - 09:57

Ok, let's verify a few things:

Where did you get the copies of the firmware that you're working with? Hopefully they came directly from Cisco, and we also need to make sure you're using the correct type of SIP image (there are 2 different ones). The SIP firmware you need is the "Non-CallManager" version, instead of the "for CCM" version.

You might want to try using the most recent version of firmware for your phone. There's an 8.9(0) version out that's more current than the copy you have. The file is called "P0S3-08-9-00.zip", and you can download it here:

http://tinyurl.com/5jwoxo

(I shrank it because it was really long)

It's possible that you can't download from that link, the free download method doesn't seem to be working. For a fresh copy of a slightly older version, go to this link:

ftp://ftp.cisco.com/pub/voice/ip-phone/sip-7960/

I tested the above link this morning, and it doesn't require a login or password of any kind.

If you're not able to download from either of the above links, hopefully you still have a copy of the .zip file you downloaded. I'd like you to work with fresh copies of the ".txt" and ".cnf" files (the other files you already unzipped should be ok to work with). When you wrote "Also, the config file I got were from the internet. In notepad they looked very messy.", I realized you have probably been opening them with Notepad.

Without getting too technical about the whole thing, you need to use the program "Wordpad" to edit these files, instead of Notepad. This has to do with how the fact that your phone doesn't run on Windows, and expects text files to be in a certain format. Wordpad will display this in a "tidy" way. If you can't find Wordpad on your computer, choose the "Start" menu, then "Run..." then type "Wordpad" (no quotes). That should launch Wordpad for you. When you attempt to open a conf or txt file with Wordpad, you need to select "All Documents (*.*)" from the "Files of type:" drop-down menu before you can select it. (See the attached screenshot.)

Make sure that your "OS79XX.TXT" file contains only the line "POS3-08-2-00" (no quotes). If you downloaded a fresh copy of the firmware from the ftp link I provided above, you definitely need to make this change.

Once you've done the above, first try placing only the following files in your "C:\TFTPD-Root" folder:

OS79XX.TXT

P0S3-08-2-00.loads

P0S3-08-2-00.sb2

P003-08-2-00.bin

P003-08-2-00.sbn

This way we can isolate the "firmware upgrade" process from a "combined firmware-upgrade and settings-configuration" process.

Follow the steps from my previous post and attempt to update the phone. If this works, your phone will now be running the SIP protocol and we can proceed directly to configuring the phone for service! If not, replace your ".cnf" files in the "C:\TFTPD-Root" folder and try again.

If you have to add the ".cnf" files back to the TFTPD-Root folder, make sure that your "SIPmac_address.cnf" is named "SIP00127F49393B.cnf" exactly. That is, everything must be uppercase, except for the ".cnf" portion of the filename. Your log shows that the phone can't locate some files in your TFTP directory -- so also make sure that the actual files are really in the "C:\TFTPD-Root" folder you created before - i.e.: no shortcuts (files with a small arrow icon the lower left corner).

(Note, your phone's MAC address is included in the log files you posted, which is how I got the specific file name for you to use. Don't worry about have that information on the net too much, a MAC address alone is not particularly useful information - apart from troubleshooting - as compared to usernames or passwords, which should always be kept private.)

Once again, the details from the log file in tftpd32 are very useful in troubleshooting!

Hopefully we can get you up and running! Each time we go back-and-forth you're getting closer, which is a good sign!

Cheers,

-James.

James,

I have downloaded the files from the second version. I purchased my phone from a secondhand vendor and not Cisco, so I dont have a purchase number from them to be able to get the "additional access" they talk about. I wonder if there is a way to get fresh config files?

In any case, Im goint to try this tomorrow evening and I will post the log when done.

Thanks,

again,

Tim

Actions

This Discussion