Simple IP Phone Service Issue

Unanswered Question
May 7th, 2008

I am developing an IP Phone Service. I am creating a IPPhoneTextObject and have added several soft keys. This works fine, however, on the phone (7945), If I push one of the soft key buttons, the phone displays: "That Key Is Not Active Here"

Anyone have any ideas? I sincerely appreciate your time.

Michael

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
agiaccone Wed, 05/07/2008 - 09:02

the notation is case sensitive, and the position is always the same in your code.

So replace all of the occurrences with (and obviously), and change the position valu to 1 to 4 instead of always 1 for all of the softkeys.

This way should work.

HTH,

Alberto

developer_mike_smith Wed, 05/07/2008 - 09:24

Thank you so much for the reply. I greatly appreciate it. That was a typographical error on my behalf. Here's the current XML that is generated & I still recieve the same error.

IP Phone Service

Button Configuration...

Developed By M. Smith

Button1

http://10.1.0.75/Page2.aspx

1

Button2

http://10.1.0.75/Page3.aspx

2

Button3

http://10.1.0.75/Page4.aspx

3

Button4

http://10.1.0.75/Page5.aspx

4

developer_mike_smith Wed, 05/07/2008 - 09:26

Outstanding! It was the fact that the 'Url' was not capitalized. I am greatfull for your help.

Cheers,

Michael

agiaccone Thu, 05/08/2008 - 06:46

In the lower right part of the post you'd like to rate there's a dropdown list and a button.

From the dropdown select the vote, then click submit.

bye,

Alberto

Actions

This Discussion