cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
16338
Views
21
Helpful
9
Replies

Can ping from router to internet but cannot ping from client to internet.

httptrashcan
Level 1
Level 1

Newbie here looking for help. I can ping from the router ios to the internet but cannot ping from my client to the internet. Here is my router config. Any help would be much appreciated. Thanks.

!version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Cisco1711

!

boot-start-marker

boot-end-marker

!

enable secret xxx

enable password password

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

no ip routing

no ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

ip dhcp excluded-address 10.10.10.2

ip dhcp excluded-address 10.10.10.3

ip dhcp excluded-address 10.10.10.4

ip dhcp excluded-address 10.10.10.5

ip dhcp excluded-address 10.10.10.6

ip dhcp excluded-address 10.10.10.7

ip dhcp excluded-address 10.10.10.8

ip dhcp excluded-address 10.10.10.9

!

ip dhcp pool CLIENT

import all

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 69.144.49.30

!

!

no ip ips deny-action ips-interface

!

no ftp-server write-enable

!

!

!

!

!

!

!

!

interface FastEthernet0

ip address dhcp

ip nat outside

ip virtual-reassembly

no ip route-cache

duplex auto

speed auto

no cdp enable

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

shutdown

!

interface FastEthernet4

no ip address

!

interface Vlan1

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip route-cache

!

interface Async1

no ip address

no ip route-cache

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0

!

ip http server

no ip http secure-server

ip nat inside source list 102 interface FastEthernet0 overload

!

access-list 102 permit ip 10.10.10.0 0.0.0.255 any

!

control-plane

!

!

line con 0

line 1

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

password admin

login

!

scheduler max-task-time 5000

end

1 Accepted Solution

Accepted Solutions

hey! you have the command no ip routing in your config file.

just remove it by:

rtr(config)#ip routing

View solution in original post

9 Replies 9

Richard Burts
Hall of Fame
Hall of Fame

The symptoms that you describe sound like an issue with address translation. I see that your config does include address translation. I have seen some things not work right when NAT used an extended access list and specified any. So I would suggest that you change the access list to this:

access-list 12 permit ip 10.10.10.0 0.0.0.255

and change the translate command to this:

ip nat inside source list 12 interface FastEthernet0 overload

Give it a try and let us know if it helps.

HTH

Rick

HTH

Rick

First of all Thank You for your reply. I appreciate anyone who can assist me in resolving this issue.

I changed the config as advised. There is still no change..... I am able to ping from router ios but not from pc connected to router.

Let me give some more information about how I have things setup.

Router - Cisco 1711

Has a WIC-4ESW 4 port card installed

The 4ESW is Vlan'd by default after setting router back to defaults.(From what I understand this is just a 4 port switch)

I am plugging my computer directly into port 1 of the 4ESW Card.

I am plugging the toshiba broadband modem into the 10/100 Ethernet Jack that is built into the 1711 Cisco Router.

From my computer I can ping both the internal (10.10.10.1) IP address and the external dhcp assigned ip address of the Cisco Router from my computer. I cannot ping anything past the external dhcp assigned port though. I have tried pinging both a URL and ip address to make sure it wasn't a DNS issue. My first thoughts were that it appeared to be a dhcp or nat issue. I have searched the internet for typical nat configurations and applied the configurations without any success. It is frustrating because I'm soo close I can taste it :) I'm just not sure what else to do. Thanks for your continued support.

!This is the running config of the router: 10.10.10.1

!----------------------------------------------------------------------------

!version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Cisco1711

!

boot-start-marker

boot-end-marker

!

enable secret xxx

enable password password

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

no ip routing

no ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

ip dhcp excluded-address 10.10.10.2

ip dhcp excluded-address 10.10.10.3

ip dhcp excluded-address 10.10.10.4

ip dhcp excluded-address 10.10.10.5

ip dhcp excluded-address 10.10.10.6

ip dhcp excluded-address 10.10.10.7

ip dhcp excluded-address 10.10.10.8

ip dhcp excluded-address 10.10.10.9

!

ip dhcp pool CLIENT

import all

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 69.144.49.30

!

!

no ip ips deny-action ips-interface

!

no ftp-server write-enable

!

!

!

!

!

!

!

!

interface FastEthernet0

ip address dhcp

ip nat outside

ip virtual-reassembly

no ip route-cache

duplex auto

speed auto

no cdp enable

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

shutdown

!

interface FastEthernet4

no ip address

!

interface Vlan1

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip route-cache

!

interface Async1

no ip address

no ip route-cache

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0

!

ip http server

no ip http secure-server

ip nat inside source list 12 interface FastEthernet0 overload

!

access-list 12 permit 10.10.10.0 0.0.0.255

!

control-plane

!

!

line con 0

line 1

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

password admin

login

!

scheduler max-task-time 5000

end

I think it also may be important to mention that there is another card installed on this cisco 1711. It is a WIC-1AM. A analog modem card. Used if you want dial-up backup? Anyways just wanted to give you full setup of all installed cards on router. Thanks again.

hey! you have the command no ip routing in your config file.

just remove it by:

rtr(config)#ip routing

Oussama

Very good catch. I am disappointed that I did not see it. Now if the original poster will confirm that this does resolve the problem it will be solved.

HTH

Rick

HTH

Rick

Also, in your default route use the ip address of your ISP as the next hop and not the Ethernet interface. Since Ethernet is a broadcast medium you will probably receive encapsulation errors unless proxy arp is enabled.

I also changed my default route to the static IP as advised.... again. Thank you all who assisted.

Removing the command no ip routing resolved my issue. I am connected via the Cisco 1711 right now. Thank You ALL for your help.

Thank you sir.. i have solved
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card