CME 4.1 SIP Trunk and Call Forward

Unanswered Question
May 7th, 2008

We cannot call-forward to numbers on the outside, inside extensions work fine, but it does not do anything when trying to call forward to a outside number. Any ideas?

I think I need to hairpin the call but the routers is trying to use VOIP standards to forward the call.

How can i accomplish this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Wed, 05/07/2008 - 17:20

Can you check with "debug ccsip message" and "term mon" if it the call is made and if so why it fails ?

Paolo Bevilacqua Thu, 05/08/2008 - 02:24

Hi, the call seem to be connected, do you see it connected or what else ? Do you have allow connections sip to sip in config ? Thu, 05/08/2008 - 06:02

Yes I do have sip to sip in the config. Also keep in the mind the system I am getting my SIP trunks from it a Broadvoice server.

Paolo Bevilacqua Thu, 05/08/2008 - 06:06

Check what the calling phone show, according to the router the call is connected and you should see that with "show call voice active".

chadlincoln Thu, 05/08/2008 - 04:25

Are you getting fast busy? Just silence? Can you transfer manually at all? If you can transfer manually, you have to set up a translation pattern for the redirect. For a time, we could manually transfer to somebody's cell phone but couldn't call-forward all to a phone. Let me know if you can transfer to a PSTN number first then we'll go from there. Thu, 05/08/2008 - 09:29

I cannot even transfer a call to the outside, it immediatly gives me a fast busy after I enter the first digit of the number I want to transfer to.

kgroves42 Thu, 05/08/2008 - 09:31

Not sure if this is your problem but, I just had this problem and it was an issue that we were sending the 4 digit extension as the Caller ID to the SIP trunk, which they did not like. So I had to add a translation rule to make it the main number


voice translation-rule 6

rule 1 /.*/ /14155551212/

voice translation-rule 5

rule 1 /^8/ //


voice translation-profile CID

translate called 5

translate redirect-called 6

then add that rule to my dial-peer

dial-peer voice 110 voip

description voip dial peer to Verizon

translation-profile outgoing CID

destination-pattern 8T

modem passthrough nse codec g711ulaw

voice-class codec 1

session protocol sipv2

session target sip-server

dtmf-relay rtp-nte digit-drop

fax-relay ecm disable

fax rate disable

ip qos dscp cs5 media

ip qos dscp cs3 signaling

no vad Thu, 05/08/2008 - 09:37

i have a CLID network-number command on the outgoing dial=peer to mask the extention number to the SIP trunk, that works great. Now i just need the CME system to use our mail number to call-forward/call-tranfer to the outside, because that is the only number our provider will accept a call from.

I think i need to use the "call-number local" command but I am unsure.

Paolo Bevilacqua Thu, 05/08/2008 - 09:45

That is quite possible, however the thing is that from the trace you sent, the forwarded call is accepted and connected.

We could check that are the media addresses, perhaps do expect that media is sent to you then sent back. Thu, 05/08/2008 - 10:47

OK I can now forward to the outside after i put the transfer-pattern .T in the telephone-system config. But I still cannot call forward to the outside. Any ideas? Thu, 05/08/2008 - 11:15

OK i got call-forwaring to work using the NO SUPPLEMENTARY-SERVICE SIP REFER and MOVED TEMP commands but either end cannot hear or talk to one another.

Any ideas? Sun, 05/11/2008 - 16:19

OK I have signed up for the Broadvoice bring your own device progam to test call forwarding. Guess what same problem.

I am thinking this has to be something on the CME side now.

Any other ideas?


This Discussion