Cisco 2960 switch not able to extract Inventory Report for the same using t

Unanswered Question
May 8th, 2008

I am faceing with one problem 2960 swith

If i put the smnp string like cisco@@

no tram is going to snmp server means SNMP server unable to recover

but if put the string like cisco@ is it happening

Can any help on this.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
David Stanford Thu, 05/08/2008 - 05:21

The @ character is a very important character for snmp with regards to community string indexing. The server can handle a @, but expects this to be community string indexing.

You actually shouldn't use 1 of these characters in the community string, let alone 2 of them.

a.rooprao Thu, 05/08/2008 - 05:37

when we are using 1 of this character, we dont find any problem. everything works fine. Only when we have 2 special characters like "@@" its giving problem.

Joe Clarke Thu, 05/08/2008 - 06:50

Dave is absolutely right. The '@' is a special character used by Cisco devices for dereferencing different instances of the same MIB. You must never use '@' in the community string of a switch, and you cannot use it on routers if you will be doing things like MPLS.

If you're trying to come up with odd characters for your community strings, it really doesn't help much. The strings are still passed in clear text on the wire. If you are concerned about SNMP security, consider moving to SNMPv3, or using a community string with access-lists and views to limit access.

a.rooprao Thu, 05/08/2008 - 21:39


Thank you for your clirification.

Can you please share some url:// on this so I can read and understand better.


This Discussion