Caller ID Displays 911 on caller Id on some calls

Unanswered Question
May 8th, 2008

Not all calls, but some calls display 911 on the caller ID, when the call in fact is not from 911.

I have checked with my Telco and they have verified that all the lines into this office have callerID on them.

Any suggestions or work arounds?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Brent Rockburn Thu, 02/02/2012 - 10:18

I was experiencing this same issue, I changed my dial-peer from 911 to dial-peer 1000 and the problem was fixed. Do you have any documentation on why this happens?



cogden Wed, 07/23/2008 - 08:40

I think this occurs when there is no callerid provided on the INBOUND call.

Have you been able to confirm this?

Remember callerid is determined by the person (or PSTN provider) making the call. Don't be confused with the callerid provided by the telco on OUTBOUND calls.

cogden Thu, 07/24/2008 - 13:14

Special Note on POTS Calls with Empty Calling Number Field

Assume this configuration:

dial-peer voice 1 pots

destination-pattern 9T

port 1/0:1

Now, assume that an incoming call arrives with no calling number information and is matched with the POTS dial peer based on the destination-pattern 9T command. In this case, the Cisco IOS router or gateway uses the "9" digit as the calling number and forwards the call to the corresponding device, such as CallManager or the IOS Gateway.

In order to not replace the empty calling number field, create a dummy POTS dial peer with just the incoming called-number command configured.

Because the incoming called-number statement has higher priority than destination pattern for inbound POTS matching, dial-peer voice 2 becomes the POTS dial peer used.

dial-peer voice 1 pots

destination-pattern 9T

port 1/0:1


dial-peer voice 2 pots

incoming called-number .



DMobley1022 Mon, 08/04/2008 - 19:01

We have not tried this yet, but a tech took a look and thinks that the Telco has a port on their side setup for Ground Start. He configured the voice port on the router. Now when you call this specific line the caller ID does not show 911.

cogden Tue, 08/05/2008 - 07:23

The setup consisted of a 2821 CME running IOS 12.4(15)xz1 which terminated on 8 analog FXO ports for inbound/outbound dialing.

At first CallerID was showing '911', but we changed the order of the dial-peers so that

incoming called-number .

came first for each FXO port.

Post install we discovered the “Caller id” was showing as up as Unknown.

After troubleshooting with no luck and banging my head against the wall many times I decided to lab this up in order to replicate the problem and after upgrading the IOS to 12.4.20T (CME 7.0) the Caller ID started working. I searched Bug Tracker and have not found anything related to this issue but I will assume that this is a bug and undocumented.

Before upgrade to 12.4(20T)

Debug vpm signal

Aug 1 15:54:34.587 EDT: htsp_timer_stop

Aug 1 15:54:34.587 EDT: htsp_timer_stop3

Aug 1 15:54:34.587 EDT: [0/0/0] htsp_stop_caller_id_rx. message length 0htsp_setup_ind

Aug 1 15:54:34.587 EDT: [0/0/0] get_fxo_caller_id:Caller ID receive failed. parseCallerIDString:no data.

Aug 1 15:54:34.587 EDT: [0/0/0] get_local_station_id calling num= calling name= calling time=08/01 15:54 orig called=

After upgrade to 12.4(20T)

Debug vpm signal

Aug 1 19:20:01.119 EDT: [0/3/0] htsp_stop_caller_id_rx. message length 42htsp_setup_ind

Aug 1 19:20:01.119 EDT: [0/3/0] get_fxo_caller_id:Caller ID received. Message type=128 length=42 checksum=94

Aug 1 19:20:01.119 EDT: [0/3/0] Caller ID String 80 27 01 08 30 38 30 31 31 36 32 30 02 0A 37 37 38 39 39 30 38 35 34 34 07 0F 42 52 49 54 2E 20 43 4F 4C 55 4D 42 49 41 20 94

Aug 1 19:20:01.119 EDT: [0/3/0] get_fxo_caller_id calling num=7789908544 calling name=BRIT. COLUMBIA calling time=08/01 16:20

Aug 1 19:20:01.123 EDT: fxols_callerid_done: call being answered

DMobley1022 Mon, 08/04/2008 - 16:40

we have determined the 911 Caller ID on incomming calls only happens with a specific line. All the other 3 lines work fine. So I plugged an analog phone with CID on it directly into the DMARK corresponding to the correct line in question.

I then placed calls to this line and the analog phone shows the correct callerID. It doesn't show the 911 on the CID. So it definatley is a problem with the config in the router.

DMobley1022 Wed, 08/20/2008 - 09:50

Let me add something before I tell you what the problem was. What we also noticed was that when you would call this #, it would only ring a 1/2 ring, then about 5 seconds later do the same thing over and over, you could never answer the phone call. Then if you looked at the list of missed calls, they all would show as 911.

To make a long story short, the problem was that there was a small cut in the telco lines (The telco still hasn't burried the lines at this place, they still run on the ground). After the telco repaired this cut, the line works fine and the caller ID works.

Kynnzak Thu, 01/20/2011 - 09:08

Is it the order of the dial-peers, or will the "preference" command do the same thing?

Charles Ferguson Mon, 08/22/2011 - 11:22

Have you tried.

On the CM Admin page on the trunk under Outbound
Calls the "Calling Party Selection" is "Originator" and not "Last Redirect Number-Send".


This Discussion