Hyperterminal garbage after changing bps to 115200

Unanswered Question
May 8th, 2008

I am trying to access a remote router with hyperterminal.

I want to upload an image using xmodem and I am following the cisco document.

I could get in at 9600 bps with no problem, but after changeing the confreg to allow 115200 bps, I am getting nothing but garbage in hyperterminal.

Now I cannot get anywhere

Is there anything I can do?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Giuseppe Larosa Thu, 05/08/2008 - 10:01


have you got a chance to access it via telnet ?

Because your changes apply only to the console connection.

Have you changed the Hyperterminal properties speed accordingly ?

If you had set the console port speed to anything other than 9600, it has been reset to that particular speed. Change the emulation software line speed to match that of the switch console port.

Another attempt could be that of pressing the break key during reboot to have the router to go in rommon. From where you can change the config register.

I also suggest to proceed sending the file form hyperterminal even if the output may look like garbage with hyperterminal configured for 115200 bps.

Verify also the UART capabilities on you PC (the serial port controller ) if it supports this speed.

hope to help


Richard Burts Thu, 05/08/2008 - 10:11


There are a couple of parts of your question that I do not understand very well. You talk about a remote router and about using xmodem. But xmodem works through a console connection. So are you local to the router or remote from the router?

If you changed the confreg to 115200 and if you are connected to the console port, did you then change your Hyperterm settings to 115200 - and did you stop and restart the Hyperterm connection (which seems to be necessary to get Hyperterm to pick up the new speed)?

If the console is not working for you, it might be possible to get into the router using the aux port (depending on how you have configured the router - the aux is enabled by default but some people disable it or change it). Or as the other poster suggests you may be able to telnet to the router and change things that way.



wilson_1234_2 Thu, 05/08/2008 - 10:33

I am trying to access a router at our DR side.

I have network access to that side and this router is the Internet edge router.

We recently lost power to that side and the router is booting to ROMMON and showing no image in flash.

I have an RDP connection to a server with a console session to the router.

I followed the procedures in the 2600 router to change the bps to 115200.

Since then, I get garbage and can not manage the router.

I didnt think to use the tftp method, so now I am stuck with garbage on the screen.

I have stopped and restarted hyperterminal numerous time and tried every speed.

I was wondering if the com port on the server needed to be changed also, it was on 9600, I changed it to 115200 and still no change.

I am wondering if the server needs to be rebooted for that hardware change to take affect, or if it is even an issue.

Richard Burts Thu, 05/08/2008 - 11:20


The additional explanation helps me understand what is going on. So you have a remote connection to a server, and the server has a connection on its com port to the console port of the router, and the server is running Hyperterm. Correct? And the console connection was working ok until you changed the confreg?

I started to suggest trying the aux port, but then realized that if the router is in rommon then the aux is not active and the only connection is the console.

I believe that when you changed the confreg on the router you created a mismatch in speed between the console and your Hyperterm session. I would have thought that changing the speed of the Hyperterm session, and stopping and restarting Hyperterm would have fixed it. Changing the speed of the com port might also help. I would think that you do not need to reboot the server to get the change to take. But if it is still not working, then I would suggest that you try rebooting the server.



wilson_1234_2 Thu, 05/08/2008 - 11:38

It makes sense that it is a speed mismatch, or possibly some other setting?

I have tried everything.

Could it be hyperterminal having problems with the speed?

Richard Burts Thu, 05/08/2008 - 12:09


I believe that while it is "possible" to be a problem with Hyperterm that it is not very likely to be a problem with Hyperterm. I do not have experience with Hyperterm failing to support the speed - though there are quite a few versions of Hyperterm out there and anything is possible.

I suspect that it is more likely a problem with the server com port.



wilson_1234_2 Fri, 05/09/2008 - 08:53


You were correct.

I rebooted the server with the faster com port setting and still no luck.

I had the remote guy move the console connection to a different server and everything worked ok.

What I did notice though is that even though I had the router and the hyperterminal set to 115200, it still took 2 hours to upload a 29Mb IOS file to the router.

Since I did not change the second server com port settings, could that have been the reason it took so long?

Richard Burts Fri, 05/09/2008 - 09:05


I am glad that you got it straightened out. My guess is that the UART in the com port of the first server might not support the faster speed.

I do not think that the slow speed of the upload was caused by not configuring the com port of the second server. In my experience changing the speed in the terminal emulator is generally sufficient and direct configuration of the com port is not necessary. I believe that the slow upload is just characteristic of xmodem. Remember that 115200 is still in Kbps and 29 MB is a lot of data at that speed.




This Discussion