database.pl failed

Unanswered Question
May 8th, 2008

Hello all got this error message on the server info page.. any ideas? thanks

Can't locate loadable object for module perlDbEncrypt in @INC (@INC contains: C:\PROGRA~1\CSCOpx/bin C:\PROGRA~1\CSCOpx/lib C:\PROGRA~1\CSCOpx/lib/perl/db C:\PROGRA~1\CSCOpx/lib/perl/install C:\PROGRA~1\CSCOpx/bin C:\PROGRA~1\CSCOpx/lib/perl/db C:\PROGRA~1\CSCOpx/lib/perl/db C:\PROGRA~1\CSCOpx\objects\perl5\lib/MSWin32-x86 C:\PROGRA~1\CSCOpx\objects\perl5\lib C:\PROGRA~1\CSCOpx\lib C:\PROGRA~1\CSCOpx\objects\perl5\site\lib/MSWin32-x86 C:\PROGRA~1\CSCOpx\objects\perl5\site\lib C:\PROGRA~1\CSCOpx\site\5.00502\lib C:\PROGRA~1\CSCOpx\site\lib . C:\PROGRA~1\CSCOpx/objects/perl/lib C:\PROGRA~1\CSCOpx/cgi-bin/dbadmin/pdbadmin C:\PROGRA~1\CSCOpx/objects/db C:\PROGRA~1\CSCOpx/lib C:\PROGRA~1\CSCOpx/bin) at C:\PROGRA~1\CSCOpx/lib/perl/db/Cisco/DbUtils.pm line 72

BEGIN failed--compilation aborted at database.pl line 20.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Thu, 05/08/2008 - 11:32

The file NMSROOT\objects\perl5\site\lib\perlDbEncrypt.pm must exist on your system, and have permissions for casuser. If this is not the case, your installation has been damaged.

kfulen Fri, 05/09/2008 - 11:25

I have it with the rights, whats next reinstall? 97% of LM works and one file is killing me...any way to repair it? thanks

Joe Clarke Fri, 05/09/2008 - 11:35

Honestly, self test is 100% useless. I never ask customers to provide it, and I never trust what it says. So if everything else is working, you are probably okay to ignore this.

That said, this could still be symptomatic of a larger problem. Verify that NMSROOT\bin\perlDbEncrypt.dll exists and has proper permissions.

kfulen Fri, 05/09/2008 - 11:53

Yeah 98% of LM works, My backups and purges have issues..it is a old install without alot of patches so I might start over with it.. thanks for your help

Joe Clarke Fri, 05/09/2008 - 12:01

Backups use Perl, and are VERY important. If that DLL is missing or damaged, you should consider reinstalling all of LMS to repair the problem.

Actions

This Discussion