ACE: predictor hash header Host - not working

Unanswered Question
May 9th, 2008
User Badges:

Hello,


I've a problem with the predictor has Header host.


I've a Farm of HTTP Proxy Servers which work an TCP Port 8000 and 8080.


We have configured like in the attachment but on the two proxy Servers the log shows that the Requests are balanced over both proxys for a request to the Host: http://www.gelbeseiten.de


Has anyone an idea what is wrong in my configuration?


Sven






Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gilles Dufour Fri, 05/09/2008 - 12:32
User Badges:
  • Cisco Employee,

Sven,


what version do you run ?

And do you have a trace showing this issue ?


BTW, I tested the config and it works.

However, note that the hash is done on the complete host field.



Gilles.

Sbutzek Tue, 05/13/2008 - 01:18
User Badges:

Hi Gilles,


on this system we are using the


3.0(0)A1(6.2)


I know, that this Version is removed from CCO, but i have not found any bugs wich belongs to the predictor hash host.



I know that the complete host Field is used for the hash. But my understanding is, that this is the FQDN and not more.


Sven

Gilles Dufour Tue, 05/13/2008 - 02:25
User Badges:
  • Cisco Employee,

I only tested A2.1 and there was no issue.

What I meant by the complete host filed is that some host will introduce the port number at the end, even if it is 80.

This would change the result of the hash.

That's why I'm asking a trace for.


Gilles.

Actions

This Discussion