UCM 5.1.2 Licensing issue

Answered Question
May 9th, 2008
User Badges:

I have 105 phones and 420 licenses. I'm only using 412 licenses. The License Unit Report has always reported correctly, but now it states that there are no authorized licenses, 412 used and -412 remaining. It seems as if it thinks I'm using all of my devices without licenses. I am having NO issues with nodes or phones working. I need to upload 40 more phone licenses, but I'm a little weary about this display. Anyone seen this?

Correct Answer by a.gooding about 9 years 2 months ago

everything worked properly. i could not add any new phones at that time though until i reloded the licenses.


when the new license was uploded that worked and had no further issues.




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Rob Huffman Fri, 05/09/2008 - 11:44
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Steve,


I have worked with a couple of people here who ran into this(a negative - value in the DLU Licensing). In both cases they had not ever received the Permanent DLU License file from Cisco. I think that you are right in not loading the new files until this issue has been resolved.


Migrating from Cisco Unified CallManager 4.0(x) to 5.0(x) same for Migration to 6.x :)


When you migrate from Cisco Unified CallManager version 4.0(x) to 5.0(x), the licenses that are required for existing phones and existing Cisco Unified CallManager nodes is calculated and an intermediate file (XML file) that contains these license counts will be generated during the Cisco Unified CallManager migration process. These licenses are given free of cost because you are already using these phones for Cisco Unified CallManager version 4.x. If you are provisioning new phones and nodes after migrating to Cisco Unified CallManager 5.0(x), you need to paste the intermediate license file in the License Registration window on CCO.


Use the following procedure to register existing licenses and request for new licenses.



--------------------------------------------------------------------------------


Step 1 In Cisco Unified CallManager Administration, choose System > Licensing > License File Upload. ***(On the new 5.x or 6.x build)


The License File Upload window displays.


Step 2 Click View File. A pop-up window displays that has the license information for existing phones and nodes. Copy this information. To copy the contents on this windrow, you can use Ctrl-A (Select All) and Ctrl-C (Copy).


Step 3 On the License Registration window of CCO website, in the text box provided, paste the file contents using Ctrl-V.


Step 4 You must enter the MAC address of the Cisco Unified CallManager server that you are requesting the licenses for, and a valid E-mail Id.


Step 5 To obtain the actual license file, click Submit. A license file is generated.


Step 6 You must upload the license file to the server with the matching MAC address that you provided in Step 4.


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/admin/5_0_4/ccmsys/a02licen.html#wp1100548



So they needed to complete this step;


Send an email to;


[email protected]


With this;


*Subject - Upgrade from 4.1(3) DLU License File Required


Company Name

Company Address

Company Phone

Contact Name


MAC Address of Pub/First Node


Please find attached the output from our DLU License Calculator (this is just an example):


CTI Port 0 40 0

Cisco 12 S 2 1 2

Cisco 7902 1 1 1

Cisco 7905 2 9 18

Cisco 7920 4 1 4

Cisco 7935 3 1 3

Cisco 7940 4 10 40

Cisco 7960 4 1 4

Cisco 7970 5 1 5

Cisco ATA 186 1 4 4

Cisco IP Communicator 3 1 3



Can you please forward the license file as soon as possible :)



From this thread;


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&topicID=.ee6c829&fromOutline=true&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1ddfc395/14



Hope this helps!

Rob

spotlight41 Sat, 05/10/2008 - 07:10
User Badges:

Rob,

thanks for the insight, but does this apply if I originally built the system on 5.1.2 and I am still on that version. I've never upgraded versions on this system. This just happened out of the blue, unprompted by any change (at least that I know of).

Rob Huffman Sat, 05/10/2008 - 08:09
User Badges:
  • Super Red, 40000 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Steve,


Sorry, I should have asked about your "build" before sending that long-winded reply. I don't think that any of that does apply here :(


I would be tempted to reload the original License file but I would contact Tac first just to be sure. Tac does not usually deal with licensing but this is more of a CCM issue it seems to me. Don't load the new 40 DLU License until this has been resolved. Because the DLU licensing is cumulative you may end up with - 372 showing which will just compound the problem.


Please let us know what you find out and what the final resolution is.


Again, sorry for not being more help here.


Rob

spotlight41 Mon, 05/12/2008 - 03:44
User Badges:

Thanks for your efforts. TAC is wanting to send me a file to upload which would renew all of my licenses in one file. I'm really more concerned as to why this happened, but they are resolute in just fixing it. We'll see. Thanks.

a.gooding Mon, 05/12/2008 - 17:59
User Badges:
  • Bronze, 100 points or more

i had a fairly similar issue on our 5.x install. the license unit file that was sent, uploaded sucessfully, but when we restarted it went away for whatever reason and we had to manually upload again.


fix was cisco issued a new licensing file.

spotlight41 Tue, 05/13/2008 - 03:55
User Badges:

a.gooding,

When your uploaded license files "went away", did all of your phones still work as normal? Everything in my environment works fine, but the display of the licenses is wrong now. I'm not sure if I could add a phone at this point or not. TAC did issue me a new license file, I'm just concerned with uploading it on top of my old files, and not knowing what caused the issue in the first place. I don't want to load and then everthing stops working. Thanks.

Correct Answer
a.gooding Tue, 05/13/2008 - 05:05
User Badges:
  • Bronze, 100 points or more

everything worked properly. i could not add any new phones at that time though until i reloded the licenses.


when the new license was uploded that worked and had no further issues.




spotlight41 Tue, 05/13/2008 - 05:09
User Badges:

Thank you. That's the feedback that I needed. I've had so many issues with this version that I'm almost afraid to touch it. On top of all that, I lost a motherboard to my Publisher a couple of weeks ago and failover wasn't configured correctly. Thanks again.

a.gooding Tue, 05/13/2008 - 13:30
User Badges:
  • Bronze, 100 points or more

i know your pain, but dont worry things get better once everthing is settled. as for the motherboard, geez thats tough.


i really didnt have the energy to ask why my licenses were acting in that manner but maybe someone might have a better explanation as well.


Also just a note, testing is key to ensure that the system works properly. If failover wasnt configured properly, i think you should probably run a check to see if everything else is fine.

thanks

spotlight41 Wed, 05/14/2008 - 03:54
User Badges:

yeah, I plan on testing soon. Another thing (that's a bit funny now, but not at all then), when my Pub motherboard died I broke the power connection to the HD backplane. Luckily this was only for one of the mirrorred drives. So I have to replace that soon. Thanks for the help.

Actions

This Discussion