switch config on poe

Unanswered Question
May 10th, 2008
User Badges:

WHATS WRONG WITH THE BELOW CONFIG


FINDINGS;

-WHEN PHONE IS PLUGGED TO INT F0/13, IT WAS ABLE TO REGISTER TO THE CME ON THE VG.

-SOME PORTS ON F0/1-12 WORKS FOR PHONES AND SOME JUST DONT


COMMON CONFIG OF PORTS FO/1-12

interface FastEthernet0/1

description PHONE_PC

switchport access vlan 101

switchport trunk encapsulation dot1q

switchport mode access

switchport voice vlan 601

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast





CONNECTION TO THE VOICE ROUTER

interface FastEthernet0/24

description VOICE_GATEWAY

switchport access vlan 601

switchport trunk encapsulation dot1q

switchport mode access

switchport voice vlan 601

spanning-tree portfast



DEDICATED USER DATA VLAN

interface FastEthernet0/13

switchport access vlan 101

switchport mode access


INT VLAN 101

IP ADDRESS 10.101.1.1 255.255.255.1


INT VLAN 601

NO IP ADDRESS



interface FastEthernet0/24 IS CONNECTED TO THE VOICE ROUTER HAVING THE VG IP ADDRESS OF 10.61.1.1



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Rob Huffman Sat, 05/10/2008 - 08:46
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Celso,


Hope all is well with you :)


I would try removing this line from the Ports that connect to IP Phones;


switchport trunk encapsulation dot1q


It is unnecessary to configure the switchport in Trunk mode because when you use the Voice VLAN (with a native vlan) command a "special" dot1q trunk is automatically setup. The reasons I have seen to support this setup are many and vary from minimizing Trunking overhead to ease of configuration and everything in between :) On the older 3500XL Switches the Trunk method was the only way to go, but on all newer versions the need for Sitchport mode Trunk is not necessary. Here is one of the better threads I have ever read on this issue (with some Tac links as well). There are some great answers from Mahesh,Paolo Sankar and others here.



http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddd5905/14#selected_message


This good link was kindly provided by Jaime;


How to configure a Catalyst switch port to connect to a Cisco IP phone


http://www.ciscotaccc.com/kaidara-advisor/lanswitching/showcase?case=K33524366



Hope this helps!

Rob


cfajardo1_2 Sun, 05/11/2008 - 06:59
User Badges:

with the port connection to the voice gateway, do we realy need to configure


- switchport access vlan 601




CONNECTION TO THE VOICE ROUTER

interface FastEthernet0/24

description VOICE_GATEWAY

switchport access vlan 601

switchport trunk encapsulation dot1q

switchport mode access

switchport voice vlan 601

spanning-tree portfast

Rob Huffman Sun, 05/11/2008 - 07:03
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Celso,


For that port I think you could actually delete these two lines;


switchport trunk encapsulation dot1q


switchport voice vlan 601


Hope this helps!

Rob

shaw.chris Tue, 12/02/2008 - 06:42
User Badges:

Does Auto QOS need to be set up on the switchport that connects to the CME Router?

Actions

This Discussion