Unity DiRT cmbRestore Errors

Unanswered Question
May 10th, 2008

We are running DiRT to move a 5.0(1) system to new hardware. We received three different cmbrestore errors during the restore process:

1. "Error in cmbRestore routine:Path not found"

2. Error in cmbRestore routine:ActiveX component can't create object.

3. "Error in cmbRestore routine:Object variable or with block variable not set"

It looks like these errors can generally be ignored. Is this correct?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ivillegas Thu, 05/15/2008 - 05:51

I would need to see the entire log file created by the restore process to put those messages into some kind of context.

lindborg Fri, 09/26/2008 - 08:41

We never got logs to look at so no... if you have your full log (presumably clicking through the registration dialogs), send it along.

Right off hand it sounds like a shared component (i.e. an event log interface or scheduler control) got unregistered along the way - should be easy enough to run down with a log to point the way.

dandrools Fri, 10/24/2008 - 11:50

I've seen these errors as well.

Here is a DiRT Restore log with 2 of the 3 above errors for reference. It appears to occur during the "Making sure current account has SA access rights" step.

It may also be worthwhile to note that immediately after running the restore, upon attempting to open UTIM I ran into CSCsi54038, which fixed that problem. UTIM worked fine before the restore.

r.stockton Fri, 07/31/2009 - 10:22

Resurrecting an old thread. I'm doing a 4.1(1) upgrade to 7.x migrating to new hardware.

So far, I have 4.1(1) on the new box and have installed the latest DiRT recovery tool (along with the latest DiRT backup on the old box). Running the restore gives the following errors;

7/31/2009 12:54:45 PM: (error) in cmbRestore routine:ActiveX component can't create object number= 429

7/31/2009 1:05:54 PM: (error) in cmbRestore routine:Object variable or With block variable not set number= 91

I have attached the log for review.

Question is...am I OK to procede with the Upgrade and address post install or should this be addressed first - and how?

Thanks!

lindborg Fri, 07/31/2009 - 11:37

the global sync looks like it threw an error trying to kick it off - As long as all the user were linked up to their AD objects properly during the local sysnc it should be ok - I'd open the DB directly (enterprise manager or CUDLE) and check the DirectoryId value in the subscriber table - if any of them are blank/NULL then these users were not synched to AD properly and you'll need to figure it out. If everything has a value there then you're OK.

r.stockton Fri, 07/31/2009 - 11:58

The DirectoryId values in the Subscriber tables are all propagated save for the Unity Installer Account (Alias = Installer)- this one is blank.

suggestions?

lindborg Fri, 07/31/2009 - 12:07

that one is always blank - it's subscriber type is "0" which means it doesn't get tied to an account in AD - I think you're fine.

Actions

This Discussion