Please help with increased CPU use with BGP even for.....

Unanswered Question
May 10th, 2008

Hi,

I have put two 6506s, SUP 720 (different type of 720) and configured BGP on it as posted in one of my earler posting.

it worked greate and I was advertising 4 blocks to two different providers for edundancy and load-sharing but only for the first 3 hours and after that a very streange latency started to show up. CPU utilization was at 99%.

I then, stoped advertising 4 blocks and only advertised 0ne /24 block which was used for the connectivity between devices for EIGRP and put some hosts behind it with one minitoring. I also changed the received routes to default only but still will Ping at 60 second cycle on baisc SUP 720, the CPU utilization reached 55%!? i.e. at 80kbps!?

the similar 6506s swerving inside the network in EIGRP, and hosting some VLAN interfaces don't behave like this!?

so, no matter how we configure BGP, it soikes the CPU utilization and bring sthe network to its Knesss!

I also have IPS writing dynamic (complied) or Turbo ACL in these routers running BGP to the providers.

Please advise if youhave had similar experience or happen to know something that needs to be confifured, setup or turn on, I don't know , may be mls rate limit?????!

these switches are refurbished but will be on Smartnet in a few days as the quote ahs been proccessed.

HERE IS THE BGP CONFIGURATION ON ONE OF THE ROUTERS AND THE OTHER ONE IS THE SAME EXCEPT WITH DIFFERENT PREFIX FOR SAME BLOCK FOR REDUNDANCY AND LOAD SHARING.

router bgp xxxx

no synchronization

bgp log-neighbor-changes

network 198.xxx.xxx.0 mask 255.255.255.0

network 216.xxx.192.0 mask 255.255.240.0

network 216.xxx.224.0 mask 255.255.224.0

network 216.xxx.224.0 mask 255.255.240.0

neighbor 209.xxx.122.xx remote-as xxxx

neighbor 209.xxx.122.xx description to NAME

neighbor 209.xxx.122.xx prefix-list default in

neighbor 209.xxx.122.xx prefix-list New-NAMEblock out

no auto-summary

!

ip classless

ip route 198.xxx.144.0 255.255.255.0 Null0

ip route 209.xxx.122.208 255.255.255.248 209.xxx.122.225

ip route 209.xxx.122.224 255.255.255.240 209.xxx.122.225

ip route 216.xxx.192.0 255.255.240.0 Null0

ip route 216.xxx.192.0 255.255.248.0 Null0

ip route 216.xxx.201.0 255.255.255.0 198.xxx.144.2

ip route 216.xxx.202.0 255.255.255.0 198.xxx.144.2

ip route 216.xxx.224.0 255.255.224.0 Null0

ip route 216.xxx.224.0 255.255.240.0 Null0

!

!*********************************************************************

!As you see two prefix to advertise out commented out to see how the

!CPU behaves with one block advertised only?

!

!Similar BGP configuration but different prefix for /21 and /20 fro redundancy to the

!second Provider.

!**********************************************************************

!ip prefix-list New-NAMEblock permit 216.xxx.224.0/19

!ip prefix-list New-NAMEblock permit 216.xxx.192.0/20

ip prefix-list New-NAMEblock seq 5 permit 198.xxx.144.0/24

!

ip prefix-list default seq 5 permit 0.0.0.0/0

Regards,

Masood

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
m-abooali Thu, 05/15/2008 - 06:15

Thanks for getting back to me. I will be turning this circuit up again this comming weekend.

I will send the output files. currently our blocks are advertised through the two OLd OC3s over different harware but the router 6506s in question, are stil talking to each other using EIGRP ans BGP shows blocks advertised only the Ints are shut.

Please advise if still the output of these commands are needed.

Regards,

Masood

Actions

This Discussion