ASA5520 primary F/W not loading new image

Unanswered Question
May 11th, 2008

The 'primary' firewall will not load the new image 803, but the secondary one did. Everytime I specify the boot system to the new image and reload, it still comes up with the old 721 image...How can I force the boot process to load the new image?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lcobbins2 Mon, 05/12/2008 - 04:37

Here's the requested info:

5 -rw- 1530 06:44:34 Dec 12 2005 old_running.cfg

2714 -rw- 8202240 17:04:38 Jun 26 2006 asa721-k8.bin

4719 -rw- 5539756 17:05:54 Jun 26 2006 asdm521.bin

6 -rw- 37732 09:24:00 Dec 14 2005 admin.cfg

6943 -rw- 139735 19:23:30 Aug 01 2007 primary.txt

6978 -rw- 153569 19:24:12 Aug 01 2007 backup.txt

6939 -rw- 137466 18:34:54 Aug 09 2007 backup-8-9-2007

7051 -rw- 7295568 14:54:54 May 10 2008 asdm-611.bin

boot system disk0:/asa721-k8.bin

boot system disk0:/asa712-4-k8.bin

boot system disk0:/asa803-k8.bin

JORGE RODRIGUEZ Mon, 05/12/2008 - 06:21

Thanks for the information, from what I see in the dir output for your filesystem disk0 that you do not have asa803-k8.bin code in it, are you using a CF (compact flash card) in this firewall? if indeed you downloaded the 803 code you need to find out where it landed if it went to the CF card or something, firewall is not finding the code you have specified in your boot statement, can you do show file system to look at the complete storage file system locations,If not then re-download the image pointing to disk0 to make sure it is copied in it.

Rgds

-Jorge

lcobbins2 Mon, 05/12/2008 - 06:54

File Systems:

Size(b) Free(b) Type Flags Prefixes

* 62947328 41226240 disk rw disk0: flash:

- - disk rw disk1:

- - network rw tftp:

- - opaque rw system:

- - network ro http:

- - network ro https:

- - network rw ftp:

JORGE RODRIGUEZ Mon, 05/12/2008 - 11:33

So where is the 803 code that you had installed? you would need to re-install it in disk0.

asa#copy tftp disk0:/asa803-k8.bin

you already have asdm-611.bin there so no need to down load it.

After you properly download it issue dir to make sure it is installed in disk0.

your new boot statement should be:

asa(config)#boot system disk0:/asa803-k8.bin

your new asdm statement should be:

asa(config)#asdm image disk0:/asdm-603.bin

once these statements are entered verify them before reload.

asa#show run | inc boot

asa#show run | inc asdm

then reload

HTH

-Jorge

Actions

This Discussion