Aironet 1252g slow performance

Unanswered Question
May 11th, 2008
User Badges:

I have a Cisco Aironet 1252g setup and I have 2 PCs using linksys N adapters connecting to it. Speed is comparable to G. Is there something special I should be doing to improve the speed. I setup the AP within line of site and only about 50 feet away and the speed is still poor.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Scott Fella Sun, 05/11/2008 - 17:30
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

What is your Linksys speed showing? If it shows 54 Mbps or less, then yes you will have comparable speeds since you are not running 'N'.


You might have to verify that you have 40Mhz channel width and the other necessary configurations.

Scott Fella Mon, 05/12/2008 - 11:37
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Then you have to configure the ap to use the 40mhz channel width and you will be good to go.

j_Pearcy00 Wed, 05/14/2008 - 14:51
User Badges:

ok I have got the speed issue taken care of but I cannot get the AP to run at the N data rates unless its not encrypted. I see these messages from the AP: Interface Dot11Radio0, Mcs rates disabled on vlan 0 due to not using AES encryption or encryption is not disabled . The only way I can see to use AES is to use AES CCMP. Is there a way around this?

Scott Fella Wed, 05/14/2008 - 15:57
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

WPA is not supported.... Use WPA2 with AES and you will be good to go.

j_Pearcy00 Wed, 05/14/2008 - 16:22
User Badges:

The only options for ciphers are:

wep 128

wep 40

TKIP

CKIP

CMIC

CKIP-CMIC

TKIP+WEP 128

TKIP+WEP 40

AES CCMP

AES CCMP + TKIP

AES CCMP + TKIP + WEP 128

AES CCMP + TKIP + WEP 40


There is no plain old AES

Scott Fella Wed, 05/14/2008 - 16:24
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Try AES CCMP.... I guess this is autonomous AP?

j_Pearcy00 Wed, 05/14/2008 - 17:07
User Badges:

this is autonomous ap yes. AES CCMP requires Radius?

Scott Fella Wed, 05/14/2008 - 17:28
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Can't find the info on autonomous but you might try this:


ap# configure terminal

ap(config-if)# ssid

ap(config-ssid)# wpa2-psk ascii

ap(config)# interface dot11radio 0

ap(config-ssid)# ssid batman

ap(config-if)# exit


http://www.cisco.com/en/US/docs/wireless/access_point/ios/release/notes/12_4_10b_JA3rn.html#wp291685


j_Pearcy00 Thu, 05/15/2008 - 06:00
User Badges:

Yeah that dosent work. Everything that I read says that AES CCMP requires radius. There is no option for just AES only AES CCMP

Scott Fella Thu, 05/15/2008 - 09:27
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

I guess the code doesn't yet support WPA2-PSK. I know for sure that it works in an lwapp environment. Weird that you can't configure that. All other options will require a radius server though.

cuevas Tue, 02/10/2009 - 14:09
User Badges:

I did this as well, and my PCs seem to be better, but the MACs are still having issues. I'm using my 1252G Access Points as LWAPP with a WLC 4402.

ericgarnel Wed, 02/11/2009 - 07:09
User Badges:
  • Gold, 750 points or more

Have you enabled wwm allowed or required under the wlan QOS tab?

cuevas Wed, 02/11/2009 - 09:15
User Badges:

I have the wmm set to allowed on the Data SSIDs, and its set to Required on my SSID for Voice

Actions

This Discussion