QOS Configuration - Help Required

Unanswered Question
May 11th, 2008
User Badges:
  • Gold, 750 points or more

Hello Experts,


My Total Internet Bandwidth: 100Mbps


1) For 1 source Public IP to Internet (any) 4Mbps needs to be reserved


>> NAT will be done in the firewall


2) For any IP to one Destination Public URL some bandwidth needs to reserved or traffic prioritization


>> "Proxy IP address". It will be one or two IP addresses to destination URL (we can do by IP address)


Also, let me know whether to Apply in Inside LAN Interface or in the Outside WAN Interface.


Kindly help with Sample Configuration.


Best Regards,


Guru Prasad R

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
izackvail Sun, 05/11/2008 - 21:12
User Badges:
  • Bronze, 100 points or more

Hi Guru, you could use LLQ. First create an access-list to classify the traffic.


access-list 101 permit ip any host 10.10.10.20 eq www


access-list 102 permit ip any host 10.10.10.25 eq www


Then create a class-map to apply your access-list.


class-map DEST_1

match access-group 101


class-map DEST_2

match access-group 102


Then prioritize the traffic with a policy-map.


policy-map PRIORITY

class DEST_1

priority 4000

class DEST_2

bandwidth 4000

class class-default

fair-queue


And finally apply it to the interface.


interface s1/0

service-policy output PRIORITY


Traffic can only be policed classified or marked inbound so you would need to do this on the wan interface outbound.


Joseph W. Doherty Mon, 05/12/2008 - 03:39
User Badges:
  • Super Bronze, 10000 points or more

What Izack provides shows the general idea. You identify your two special groups into two classes using class-maps that likely will use ACLs to match the traffic of interest. Within an outbound policy, specify how each of the two classes, and everything else, are to divide up your 100 Mbps.


Izack's example ACLs should be close to meeting your #2 requirement, but for you #1 requirement, in might be something more like:


access-list 101 permit ip host (your pub IP) any


Also with Izack's example, your #1 requirement didn't ask for absolute priority or to cap that traffic to just 4 Mbps. So, I would recommend using a bandwidth statement rather than a priority statement.


You didn't mention what bandwidth you wanted to provide for requirement #2, so you can set the bandwidth statement in the class DEST_2 as desired.


PS:

One other thing to note, in Izack's example, FQ in class-default, on most Cisco platforms (I believe), can distort the bandwidth reservations for other defined non-LLQ classes. I.e. on such a platform, don't use class-default with other non-LLQ classes.

izackvail Mon, 05/12/2008 - 05:41
User Badges:
  • Bronze, 100 points or more

Joseph is absolutely right, you wouldn't typically use the priority command in this situation. Priority is typically resigned for voice or video traffic because it gives strict priority over all other traffic but it also polices the traffic at the set rate. The bandwidth command gives a set average rate but it will allow the traffic to go above that rate if the bandwidth is available.

The fair-queue inside class-default is just saying to separate all traffic not matched with your other classes into separate queues for each flow. Otherwise the router would use first in first out FIFO queuing for the class-default.

bvsnarayana03 Mon, 05/12/2008 - 05:57
User Badges:
  • Silver, 250 points or more

If the natting is done on FW, then QoS can be applied to router fastethernet as service-policy out.

royalblues Mon, 05/12/2008 - 13:27
User Badges:
  • Green, 3000 points or more

Guru


Is your QoS needs only for the outbound traffic?


Internet traffic would mostly be receive and hence it may be required that the other ISP end be configured the same to achieve the QoS you desire


HTH

Narayan

guruprasadr Mon, 05/12/2008 - 19:58
User Badges:
  • Gold, 750 points or more

Dear All,


Thanks for all your POST.


HI Narayan,


Will update you with more Queries once i have an Update from my Partner. I am waiting for more information about the Requirement for the QOS at remote-end.


Again Thanks for your POST.


Best Regards,


Guru Prasad R

Actions

This Discussion