Citrix thin client issues on a LWAPP wireless network

Unanswered Question
May 12th, 2008

My customer is using a thin client application over wireless. The thin client keeps locking up and they have to reboot the client to recover.

I do not believe this has anything to do with the wireless LAN infrastructure but I wanted to see if anyone has seen this in another environment and what may have been done to resolve the problem. One thing that we did find was that when pinging from the thin client to any other device, including even it's own default gateway, the response time can vary from a few ms to over 1000 ms. Eventually the client timeout gets hit and the client locks up, requiring a reset to recover. However, when I associate to the same SSID and I am connected to the same AP as the clients we tested with, I do not see this problem. Again, this leads me to believe that the issue is on the thin client/application side.

If anyone has any experience with this client or is aware of any parameters we could tune on the WLC end, I would welcome any input. We have confirmed that the timeout value for the client is set for 3 seconds, which is the maximum timeout vlaue. Additional details are below.


V30L CE 800M128/128

Winterm 3000 series

Build 563.14

Bios/bootloader REv:1.14/BL9.0

Bootrom Chip type: SST49LF040B

Microsoft WinCE: 5.00



Thank you for any help or input anyone can provide.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Scott Fella Mon, 05/12/2008 - 08:47

The reason the client locks up is because the device lost connection to the backend server, thus wasn't able to return the devices session. What you have to do is make sure each wyse has its own login to the citrix and also tell your citrix team to enable session persistence.

bmack Mon, 05/12/2008 - 08:59

Thank you for your input. I will check on this and let you know if it resolves our issue.

Scott Fella Mon, 05/12/2008 - 11:36

Also make sure that the wireless card is configured for CAM. This way the client card will not go in sleep mode and disconnect the user.

dennischolmes Mon, 05/12/2008 - 15:49

This may or may not help your problem as the application and Citrix may have an issue with dropped packets. If you still have a problem look into session persistance issues on the client device OS registry. This will fool the OS into believing that the client never loses connectivity. It helps in some worst case scenarios. This is particularly the case with CE based devices.

bmack Wed, 05/14/2008 - 05:03

I have some additional information that may shed a more light into the problem we are experiencing.

- The lag in the ping replay times is being seen at the windows CE level before citrix is involved, but yes everyone has its own unique ID and session persistence is enabled.

- The V30L use the WYSE Atheros add on to manage the CB21AG, this add on is at the current version with the firmware ( Build 563.14 ) loaded on the V30La. There are not any xp or 2k machines running the Wireless card.

dennischolmes Wed, 05/14/2008 - 13:57

The issue is likely to be the CE drivers for the cards. CE does not handle wireless traffic nearly as well as XP or even Vista for that matter. I had a similar case that plagued a customer for 6 months and the fix was to eventually switched to the same box with embedded XP instead of CE. Disabling media sense in the registry on the CE devices helped some with the problem but did not cure it. CE is a PDA operating system and as such was not really intended for enterprise use. I would begin early on to test the same software on a laptop PC with XP and see what the results are. If you see no problems on XP save yourself the grief and suggest a client change to Wyse.

bmack Fri, 05/16/2008 - 07:46

Thank you to everyone who helped me with this issue. In the end, the AIR-PI21AG card is not supported on CE. The OS's supported ar XP & 2003 per the data sheet.

It is a listed bug. See the following if you happen to run into this.

CSCeg80892 Bug Details

CB21AG Wireless Card locking up Wyse WT9455XL(thin client device)


AIR-PI21AG lock up the Wyse WT9455XL(a thin client device).


This symptom is observed in version 1.1 and 1.2.

The lockup can be recreated by going to device settings in XP, sorting the

devices by resources and

clicking on sort by IRQ a couple of times. Box locks hard (including the

mouse). This only occurs

when radio is switched on. If this is not done, the box will generally run for

a few hours,

connected to the WLAN before locking hard.

Thank you all again :-)


This Discussion



Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode