"csim start" command issue

Unanswered Question
May 12th, 2008
User Badges:

I am working with a 2811 ISR. The unit is using a single PRI to the PSTN. One small issue is that the customer has only a PVDM16 and therefore not enough DSP's to support the full PRI. I have told them to add another PVDM16. In the mean time I have configured the controller to use only 16 timeslots. When I test the ISR using the "csim start" command to any number I get the error below:


Voice-Lab#csim start 96472891369

csim: called number = 96472891369, loop count = 1 ping count = 0


csim err:csim_do_test invalid major major(16) minor(0)

csim: loop = 1, failed = 0

csim: call attempted = 1, setup failed = 0, tone failed = 0


Voice-Lab#

May 9 13:12:29.470: ISDN Se0/0/0:23 Q931: Applying typeplan for sw-type 0x5 is 0x0 0x0, Called num 6472891369

May 9 13:12:29.470: ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8 callref = 0x008A

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Called Party Number i = 0x80, '6472891369'

Plan:Unknown, Type:Unknown

May 9 13:12:29.474: ISDN Se0/0/0:23 Q931: TX -> DISCONNECT pd = 8 callref = 0x008A

Cause i = 0x80AF - Resource unavailable, unspecified

May 9 13:12:29.562: ISDN Se0/0/0:23 Q931: RX <- RELEASE pd = 8 callref = 0x808A

May 9 13:12:29.566: ISDN Se0/0/0:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x008A


I have attached my config. Any thoughts as to why this would be happening? TIA!





Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Brandon Buffin Mon, 05/12/2008 - 07:24
User Badges:
  • Purple, 4500 points or more

What does "show isdn status" indicate?


Brandon

flash2200 Mon, 05/12/2008 - 07:31
User Badges:

Up at Layer 2 and 3. (First thing I checked :)

shyamkumar.puppala Fri, 07/03/2015 - 10:03
User Badges:

XXXXXX#csim start 91XXXXXXXXX
csim: called number = 91XXXXXXX, loop count = 1 ping count = 0
.
csim: loop = 1, failed = 0  
csim: call attempted = 1, setup failed = 0, tone failed = 1

XXXXXXX#

 

 

Here tone failed=1.

 

What does it means whether issue at ISP or at local.

 

how can we confirm issue at ISP

 

 

 

Carlo Poggiarelli Fri, 07/03/2015 - 11:03
User Badges:
  • Green, 3000 points or more

Hi.

You have different debug option to use with  csim to determine where the issue belongs

In case of isdn debug isdn q931 

in case of sip debug ccsip messages

in case of analogue line

debug vpm signal

 

HTH

 

Regards

 

Carlo

 

paolo bevilacqua Mon, 05/12/2008 - 08:27
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

They are not taking the call on channel 1, ask telco on which channel they start for your originated calls. You can configure timeslots 16-31 to try anyway.

flash2200 Mon, 05/12/2008 - 10:05
User Badges:

Thanks Paolo,


I will check this tomorrow when I am back at the client site.

Actions

This Discussion