Grabbing IOS from TFTP

Unanswered Question
May 12th, 2008

I am trying to have my router/switch pick its IOS up from a tftp server. I transferred the .bin file to my tftp server and then issued.

boot system <file> <address of tftp>

I also tried

boot system tftp <file> <address of tftp>

I did both of these, FTP as well, but had no luck. I tried this on my 3640 and 3725 routers. The ideal goal is to have these routers pick up the IOS from the tftp server and then load it up like normal. Is this possible? And am I doing it correct?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Richard Burts Mon, 05/12/2008 - 19:10


I would think that boot system tftp would work much better than boot system . When the router is booting up is it able to access the tftp server? (it would reach the tftp server if it were on the connected subnet with one of the iterfaces). If the tftp server is not on a connected subnet then I suggest that you add ip default-gateway to the config where is the address of the gateway that can connect the router to the tftp server.

If that does not solve the problem then please try the boot from tftp and post all of the console messages during the boot process. Perhaps the console messages will help identify the problem.



rebrokenglass Tue, 05/13/2008 - 05:38


Yes it is in the same subnet, but it appears it never makes the connection to the server. I am quite perplexed as to whats going on with TFTP and even FTP for that matter. I am able to dump IOS and config files when the router is on, but then for no reason I will lose access to the the server.

In the case of FTP I setup an anonymous account with no password and transferring the files to the server worked without a hitch, but upon boot it did not appear to grab the IOS. So I guess its more of a TFTP problem now. I am using tftpd32 and have never had issues like this. Any suggestions on TFTP servers?

yjdabear Tue, 05/13/2008 - 07:27

How are the "boot system" statements sequenced in your startup-config?

rebrokenglass Tue, 05/13/2008 - 07:30

Its just the single TFTP boot command. I did not append any further boot system statements after (flash or ROM). I assume they would follow if TFTP failed.

Richard Burts Tue, 05/13/2008 - 07:32


I agree that seeing the detail of your boot system commands would be helpful. Also as I requested earlier please try to boot the router using tftp, and post all of the console messages that are generated. These may help us to see what the problem is.



Martin Ermel Fri, 05/16/2008 - 14:11

I would say the command should be

boot system tftp://x.x.x.x/file_name

instead of boot system


boot system tftp

To give it a try, first issue a 'no boot system' in config mode followed by a

'boot system tftp://x.x.x.x/file_name'

and see if it is successfull.

(x.x.x.x is the IP address of your tftp server)


This Discussion