user tracking acquisition problem

Unanswered Question
May 12th, 2008

Our client has Ciscoworks LMS 3.0 with Campus Manager 5.0.0. Just last week he encountered problems with user tracking acquisition. From a total end hosts of 545 now it only sees 9 end hosts.

I noticed that when I ran the "start UT acquisition" the process name UTMajorAcquisition is running normally. But when the start UT acquisition turns "idle" the UTMajorAcquisition is "Transient terminated."

Tried to access the Debugging Options but can't open the file.

I've also attached herewith the pdshow result of the server. Do you think we need to upgrade the version of Campus Manager?

Appreciate your help on this.

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 05/12/2008 - 20:13

Transient terminated is a healthy state for UTMajorAcquisition. It means that an acquisition has been run, then and was completed. What was the exact error you got when trying to access debugging options?

benjo.rulloda Thu, 05/15/2008 - 01:42

Hi Joe,

We installed an update on our Ciscoworks LMS 3.0 with CiscoWorks_LMS_3.0_Dec_2007_Update.exe but were still encountering user tracking problems. Were still stuck with just 9 end hosts discovered.

I tried to access the Campus Manager>Admin>Debugging Options>User Tracking Reports and open the file Cmapps.log but cannot understand what it shows.

Any idea on what else is wrong with the server? Appreciate your help on this.

Joe Clarke Thu, 05/15/2008 - 18:34

That log has nothing to do with UT acquisition. You will need to enable user tracking debugging under Campus Manager > Admin > Debugging Options > User Tracking Server. Then run a new UT acquisition.

Of course, some obvious things to check are to make sure the switches with missing users show up properly on the Topology Map with a green switch icon. If you are using SNMPv3, make sure you are running code on the switches which support SNMPv3 contexts, and you have properly configured the switch to allow context polling.

benjo.rulloda Sun, 05/25/2008 - 23:15

Hi Joe,

We have this configuration on our switches:

snmp-server group ***** v3 auth write *****

snmp-server view ***** internet included

snmp-server user ***** ****** v3 auth md5 *****

snmp-server host 192.169.1.130 version 3 auth *****

I have changed some parameters with an asterisk but those are mainly usernames and passwords.

Is there something lacking on our configuration?

Joe Clarke Sun, 05/25/2008 - 23:25

You have not configured any support for polling SNMPv3 contexts. You need to run "show snmp context" and for each context listed, add a line :

snmp-server group **** v3 auth context CONTEXT

Only then will User Tracking be able to poll for MAC addresses in each of the VLANs on the switch. Note: SNMPv3 contexts are not nor ever will be supported on 2950 series switches, or any device running 12.1 code.

benjo.rulloda Sun, 05/25/2008 - 23:32

The "show snmp context" shows all my vlans for the switch. Where will I configure the line "snmp-server group **** v3 auth context CONTEXT"? On global configuration?

benjo.rulloda Mon, 05/26/2008 - 15:55

I can enable it globally but one entry for each VLAN context? How do you do that? I have an option of access-list on the command: snmp-server group ***** v3 auth context CONTEXT access. Do I have to configure access-list on it to permit vlans?

Joe Clarke Mon, 05/26/2008 - 16:01

You have to type the command I mentioned once for each VLAN context. The commands do not overwrite each other. They will be appended to the config. You can add your ACL on the end if you want.

benjo.rulloda Mon, 05/26/2008 - 16:17

I have no option of VLAN on the command you've given me. Even if I go to the interface vlan configuration, there is no available command for snmp-server group. Or even on the vlan configuration there is no option for snmp. How do I do this VLAN context configuration?

Joe Clarke Mon, 05/26/2008 - 20:29

Use the command I sent you previously. For example, say you have a context called vlan-6. You would configure:

snmp-server group v3group v3 context vlan-6

You need to do this for every VLAN context.

benjo.rulloda Tue, 05/27/2008 - 00:47

Hi Joe,

We have already configured the snmp context command as you have said on our client's Cisco 3550 but user tracking is still not working. Here's how I configured it:

switch(config)# snmp-server user trendsadmin tr3nd5n3tw0rk v3 auth md5 [email protected]

switch(config)# snmp-server group tr3nd5n3tw0rk v3 auth write trendsRW

switch(config)# snmp-server view trendsRW internet included

switch(config)# snmp-server host 192.169.1.130 version 3 auth trendsadmin

When I do a show run on the switch, here's what I get:

switch# show run

snmp-server group trendsadmin v3 auth notify *tv.FFFFFFFF.FFFFFFFF.FFFFFFFF.FFFFFFF

F0F

snmp-server group tr3nd5n3tw0rk v3 auth write trendsRW

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-1

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-2

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-3

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-4

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-8

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-13

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-14

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-15

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-16

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-17

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-54

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-55

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-56

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-57

snmp-server group tr3nd5n3tw0rk v3 auth context vlan-99

snmp-server view trendsRW internet included

snmp-server host 192.169.1.130 version 3 auth trendsadmin

I have also attached a screenshot of the SNMP credential of the said switch. What seems to be lacking on the switch's configuration or on the snmp credential?

benjo.rulloda Mon, 06/09/2008 - 17:21

Hi Joe,

Found out that the Cisco 3550 switch was replaced by a Cisco 2950 which you said does not support snmp version 3 context command. Problem is we reverted back to snmp version 1 for all the switches including the Cisco 4500 but when I enabled user tracking acquisition, the table shows no IP address, just the mac-address and the port on the switch it is connected to.

The initial setup of Ciscoworks was that we have snmp version 1 running, then apply version 3 and reverted back to version 1 for user tracking to work again just like it did when we started running the application.

Any idea on how we can resolve this?

Joe Clarke Mon, 06/09/2008 - 20:27

IP address information is obtained from routers. Make sure that each subnet has at least one router Data Collected and that these routers all show up on the Topology Map with with green router icons. Then, make sure each router has a populated ARP cache for their respective subnets. Once that is working, a new UT acquisition should populate IP addresses.

benjo.rulloda Mon, 06/09/2008 - 20:36

Do we need to configure the snmp context command on the routers as well for UT to work on the switches?

Joe Clarke Mon, 06/09/2008 - 20:39

No. The routers simply need to be properly Data Collected by Campus. Of course, if you have any SNMP views which block the ipNetToMedia and at tables, they need to be removed.

benjo.rulloda Mon, 06/09/2008 - 21:08

Here's what we have configured on the router:

snmp-server group trendsnetwork v3 auth write trendsRW

snmp-server view trendsRW internet included

snmp-server user trendsadmin trendsnetwork v3 auth md5 trendsadmin

snmp-server host 192.169.1.130 version 3 auth trendsadmin

Do any of these block any SNMP views?

benjo.rulloda Tue, 07/22/2008 - 05:25

Hi Joe,

Our client performed Device discovery as well as data collection of all his devices but still there are no IP addresses under UT end hosts. What do you think might be the problem? Any suggestions on how we can troubleshoot it?

Appreciate your help on this.

Joe Clarke Tue, 07/22/2008 - 08:12

Are the routers showing up properly on the Topology Map with green icons? Do their ARP caches contain the proper entries which correspond to the MACs acquired by UT?

benjo.rulloda Wed, 07/23/2008 - 19:21

Hi Joe,

The routers showed up on the Topology Map as red icons. What I did was, I disabled the SNMP ver 3 of the devices and configure SNMP ver 1 and reconfigure SNMP ver 1 on Device Credentials under Common Services. From there, the devices are now in green icons and UT End hosts report is functioning properly. Since the client's requirement is SNMP ver 3, I re-enabled again ver 3 and noticed that the icons are still green and UT report is still ok.

Is this a bug with regards to LMS 3.0? Is there a way that we can resolve such problems without disabling and re-enabling the SNMP ver 3?

Joe Clarke Wed, 07/23/2008 - 19:48

I suspect something was wrong with your SNMP credentials. If you still have v3 devices failing, start a sniffer trace filtering on udp/161 for those devices, then start a Campus Data Collection. The trace should then show exactly what Campus Manager is seeing, and will tell you what the problem is.

Joe Clarke Wed, 07/23/2008 - 21:23

The problem could also be with the way you configured the SNMPv3 users. If the engineID changed after the users were configured, the users would need to be reconfigured for the correct engineID. This could also account for the behavior you were seeing.

benjo.rulloda Wed, 07/23/2008 - 23:59

Hi Joe,

This is how we configured SNMPv3 on the devices:

snmp-server user trends trendsnetwork v3 auth md5 trendsadmin

snmp-server group trendsnetwork v3 auth write trendsRW

snmp-server host 192.168.1.130 version 3 auth trendadmin

snmp-server view trendsRW internet included

Is there a problem with this configuration? And when you say SNMPv3 users, what are you pertaining to?

Joe Clarke Thu, 07/24/2008 - 06:03

No, there is nothing wrong with this, but without seeing the sniffer trace, I cannot comment on why this wasn't working for you.

Actions

This Discussion