associating the device to the ctil (clobal directory)

Unanswered Question
May 13th, 2008

Hi All;

In the call manager, when I need to associate a device to a global directory, I press on "device association" and then I press "select devices" and the problem here that I have to go page after page and check the device that I need, then I will click on the check box to select it.

How can associate the device to a global directory in an easier way of search, without going to browse the pages and searching for the device to select it? How can select the device directly?

Also, how can I list all my configured CTI ports in the call manager?

Any help?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.3 (3 ratings)
david.macias Tue, 05/13/2008 - 04:42

You could always use the select all option, but I don't think there is an easier way.


bilalghayad Tue, 05/13/2008 - 04:50

So I have to go through the pages and find the device that need to associate it, even if they are 32 pages??

From the other side, any help to know how can I list all the CTI Ports (that configured)?



gpulos Tue, 05/13/2008 - 05:23

you don't need to go through all 32 pages...

before you press the 'select devices' button, choose the 'directory number' option in the pull down menu, then put in the DN (extension) of the device you'd like to associate.

then press 'select device' and it will show the single DN and be much easier to choose.

(of course, shared lines will show multiple entries of the same DN but this is OK and normal)

bilalghayad Tue, 05/13/2008 - 05:26

Thanks a lot for your kindly help.

And to associate an IP Phone to the Globak Directory, do I need to add for it an CTI port, or I can associated it directly?



bilalghayad Sun, 05/18/2008 - 04:12

Sorry I did not understand how can I display all the configured CTI ports on the CallManager?

I will select Device --> Phone --> ??

Note: can the CTI port has DN number same as a DN number for an IP Phone?



bilalghayad Sun, 05/18/2008 - 04:21

Hi gpulos;

My CCM version is 3.3, I tried it as following and actually it did not view the signle DN, but it displayed all of the devices (exactly like no filter)!!

I did that from the following steps:

User --> Global Directory --> Search (to display all the JTAPI link) --> ICMUser --> Device Association --> I selected Directory Number and I selected is exact (or begins with) and I put 5221 which is an Phone extension --> Select Device, but it gives me the complete list of the phones and I have t go through the pages and search on the 5221 extension.

Any help why it does not filter with me?



usman.amjad Mon, 05/19/2008 - 01:47

Dear Bilal!

You should always use all the options because there is no another easier way. You should always open all pages.

noeparenteau Thu, 07/03/2008 - 10:27

My problem is the opposite.

I use CCM 4.1(3).

I need to "dis - associate" a device/DN from a User.

When I display all the devices currently "associated" to a User - I have to page, by page (64 of them) find the exact device/DN that I need to "dis-associate".

Needless to say this is a very slow (Is it ok to say tedious) way of doing things.

Help someone out there...

Yours truly,

"Next Page" Guy

noeparenteau Thu, 07/03/2008 - 12:00

Thnaks for the warning - I think...

But is there a way into the USER / DEVICE ASSOCIATIONs via the CCM Database?

I found a way into the Attendant Console Speed Dials via it's Database.

[soap-box on]

There has to be a better way to perform a "dis-associate". This is my cause d'jour...

Am I alone in this fight for "dis-association" or not!

Stand up with me now...

[saop-box off]

Help Mr. Cisco... I know your out there...


Mr. Page Next

noeparenteau Wed, 07/09/2008 - 05:18

that's it, the web page's asp.

Has anyone gone into those asp/pages/code and modified the output to be 100 lines (current display limited to 20 devices displayed per page).

If I could modify the output to 100/200/ALL/etc. devices displayed then I could use the browser EDIT/FIND to look for the device that I want to "dis-associate".

OR along the same theme (modifing asp pages)

has anyone just generated the "dis-associate" asp/html page to request a "dis-association" of a specific device?

Or am I on a limb by myself...

Point me in the right direction is an acceptable option...

Mr. Page Next

noeparenteau Wed, 07/09/2008 - 05:56

I also looked at the BAT tool, but I would have to EXPORT all devices for a specific CTIUserID and then delete the single device fromt he output file then IMPORT back in the CTIUSERID with all the devices minus the one that I deleted....whew! a long way around the block...

Me thinks I am talking to myself, but at least I am listening.:-)

Mr. Page Next

noeparenteau Fri, 07/11/2008 - 05:40

Eureka...It works!

I changed the "userprefsphones.asp" code to reflect this change:

FROM : var chunkLength = 20;

TO : var chunkLength = 2000;

as I have over 1200 devices associated with this particular USER.

The display takes a while (3 seconds in the original asp, versus 11 seconds in the modified asp) to complete, but it gives me all of the devices on one web page!

All I do now is "FIND XXXX", then check the radio box to "dis-associate" the device and Vola! Done...

PS - I have four Call Managers/7845's so I tested this on one of the Subscriber's asp file.


Then in the Browser's address field, I pointed to that Subscriber's file location (see above).

Now all I have to do is wait for Mr./Ms. Cisco to find out what I did and shake his/her finger at me.

Mr. No-Page Next guy...

usman.amjad Fri, 07/04/2008 - 00:55

You can open the Call Manager in two TABS. and can do your work easily, There is no any other option.

noeparenteau Mon, 07/07/2008 - 05:32

Dear usman.amjad,

I don't mean to sound rude but I don't think you understand what I am trying to do.

I am trying to find a specific device by using the DEVICE ASSOCIATION page of a specific CTI Userid.

This panel displays all devices associated with this CTI Userid, page by page (64 of them).

And even if I input the correct device name, the filter shows ZERO devices filtered, because, the device I am looking for is already ASSOCIATED.

I do not get an option to increase the length of the display, as I do in some other displays nor am I told wherein the 64 pages of outpuit the specific device is located, so I could easily skip to that page...

Sorry for the "rant", but am I the only one that is upset by this - should I direct my thoughts (or lack there of) to another forum? Me thinks me is getting no where and starting to make me not so likeable.

No problem. We actually understand the issue and sympathize with you.

It would have been a very useful product enhancement from the get go if you could work backwards in device association. Enter a device and it would tell you which users were associated, if any. From there it would allow you to delete user associations.

Cisco could have solved this in a number of ways.




This Discussion