"copy tftp flash" not working after crypto IOS upgrade

Unanswered Question
May 13th, 2008

Hi all,

Just upgraded a Cat3560 to IOS ver c3560-ipbasek9-mz.122-44.SE.bin and a Cat2960 to c2960-lanbasek9-mz.122-44.SE1.bin respectively. Just after upgrading I discovered there is a later release for each of these models. Now, however, I cannot get the TFTP copy to work from my TFTP server (unchanged since last upgrade) to these switches.

Symptoms:

When I do the "copy tftp flash" command and fill in all the parameters as usual the download seems to start but progress is VERY slow compared to normal. Switches advise download is complete, but only one tenth of the "!" have appeared than would appear normally. When I attempt to "verify flash:[iosname]" the switch tells me there is an error and that file does not exist. Running "show flash" shows the file DOES exist (or at least it's showing in the list) and is approximately the right size.

What I've tried:

- Tried a different TFTP server but got the same result

- Using a different switch I've been able to use TFTP from the original server to download the same image (ie. one of the above) with no problem, and faster.

- I have NOT tried using a different copying protocol

[CORRECTION] I have now tried FTP. Same result: FAILED.

[EDIT] EXTRA INFO:

I've just checked another switch (c2960) that I upgraded a few weeks ago and discovered that I cannot verify ANY of the files in flash: without getting the "file or directory does not exist" error message. It's IOS is 12.2(44)SE1 with crypto!! Maybe it's not that the file doesn't transfer, but that I just can't verify it (which makes using it in the "boot system" command path a little scary).

As usual, all help appreciated.

Cheers,

Ben.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ben_johnson Tue, 05/13/2008 - 22:59

Just tried that but it made no difference. After formatting the "flash:" and then downloading a new IOS, changing the "boot system" path and reloading I still have exactly the same problem.

What I DID discover during this process is that it only seems to be the "verify" command on the flash fs that is not working - always produces an "%Error verifying flash:[filename] (No such file or directory)" error, even though the file is visible under "show flash" and is clearly there, proven by the fact that the switch was able to reboot with the newly downloaded IOS (c3560-ipbasek9-mz.122-44.SE2.bin for the curious).

[NOTE] I also ran an "fsck" on the flash fs and it reported everything as OK.

I should also point out that I've only really tested the "verify" command, so there may be other commands that don't work either - I just don't use them at this point.

Cheers,

Ben.

Actions

This Discussion