CDP Issue(

Unanswered Question
May 14th, 2008
User Badges:



Dear ALL



If i am using CDP on my Routers iam not able to discover any CDP neighbours and

if i am using CDP on switches i am able to discover all LAN Devices

Could some body help me





Out put of CDP on my ROUTERS is below,




#sh cdp

Global CDP information:

Sending CDP packets every 60 seconds

Sending a holdtime value of 180 seconds

Sending CDPv2 advertisements is enabled

-----------------------------------------------------

sh cdp traffic

CDP counters :

Total packets output: 789061, Input: 0

Hdr syntax: 0, Chksum error: 0, Encaps failed: 0

No memory: 0, Invalid packet: 0, Fragmented: 0

CDP version 1 advertisements output: 0, Input: 0

CDP version 2 advertisements output: 789061, Input: 0

-------------------------------------------------------------

sh cdp

Global CDP information:

Sending CDP packets every 60 seconds

Sending a holdtime value of 180 seconds

Sending CDPv2 advertisements is enabled

--------------------------------------------------

sh cdp interface

Ethernet0/0 is up, line protocol is up

Encapsulation ARPA

Sending CDP packets every 60 seconds

Holdtime is 180 seconds

-------------------------------------------------

######sh cdp ne

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater


Device ID Local Intrfce Holdtme Capability Platform Port ID

#

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mahmoodmkl Wed, 05/14/2008 - 00:39
User Badges:
  • Gold, 750 points or more

Hi


Can u verify it the other end is enabled for CDP.



Thanks

Mahmood


UCBNOCWAN Wed, 05/14/2008 - 00:57
User Badges:

Hi

Other end it is enabled


from all the switches i am able to see the neghbours excpet the router.

mvandorp Wed, 05/14/2008 - 01:19
User Badges:

What is your interface configuration? Is an ACL blocking things?


Marcel


UCBNOCWAN Wed, 05/14/2008 - 18:13
User Badges:

There is ACL on ethernet interface (LAN)

Extended IP access list 141

10 deny tcp any any eq 1639 (30717 matches)

20 permit ip any any (1326742325 matches)


My ethernet config is below

interface Ethernet0/0

description ### LAN ###

ip address ##########

ip access-group 141 in

ip route-cache flow

half-duplex

standby ip ##########

standby preempt



how to configure IP CDP


Please advice on the same.

Edison Ortiz Wed, 05/14/2008 - 20:12
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

CDP is enabled by default and no need to configure it. Your original post confirms CDP is running on that interface.


Can you post the portion of the config from the switchport connected to this router?


You may be experiencing a duplex mismatch issue which is affecting CDP. I noticed your Ethernet interface is running half-duplex, you must match this duplex setting on the switchport as well.


__


Edison.

sanjay.khurana Wed, 05/14/2008 - 06:24
User Badges:

Hi,


U need to configure IP cdp on interface also.


and after that u can check the cdp status..



bmcginn Wed, 05/14/2008 - 20:09
User Badges:
  • Bronze, 100 points or more

use "cdp run" in global configuration on both devices, or if you don't want CDP on a particular interface, you can disable it on the interface using "no cdp enable"



cyptic Fri, 05/16/2008 - 04:28
User Badges:

Hi!


We need so see your complete interface configuration both for the router and for the switch. Have you configured any router interface as a dot1q-trunk? Have you changed the native vlan in some of the units?


Actions

This Discussion