mac-address flapping

Unanswered Question
May 14th, 2008
User Badges:

Hi All,

what are the possible causes of Mac-Address Flapping?


i have recived messages in my switch for the mac-address flapping ( Mac-Address 0201.0000.0000)


Thanks & Regards,

Raheel

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Wed, 05/14/2008 - 15:22
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The switch is learning the same MAC address via 2 different switchports.


__


Edison.

Pravin Phadte Thu, 05/15/2008 - 01:32
User Badges:
  • Silver, 250 points or more

can you provide with the error msg log,


if possible also the config on the switch. show tech-supp if possible.

shelgaonkar Thu, 05/15/2008 - 01:34
User Badges:

Check the OS of the machine which is connected to that port,from which the specfic mac address is identified.If it is a server OS,then disable the Network load balancing (NLB) service.


Let me know if my solution helps you.

S. Hasan Thu, 05/15/2008 - 01:40
User Badges:

yes this port is connected with win 2000 server with load balancing option.


how can i fix it widout disabling this load balanicg option at switch end.


raheel


shelgaonkar Thu, 05/15/2008 - 01:54
User Badges:

Load balancing is happening on server not switch.Remove the NLB service from TCP/IP configuration of the server

S. Hasan Thu, 05/15/2008 - 01:59
User Badges:

This is the requiremnt of the system. now i want to fix flapping message error without disabling the load balancing service.

Danilo Dy Thu, 05/15/2008 - 01:38
User Badges:
  • Blue, 1500 points or more

Hi,


Do you use etherchannel? Check your etherchannel configuration between switches.


Regards,

Dandy

Edison Ortiz Thu, 05/15/2008 - 04:50
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

If you have 'load balancing' configured at the server, you must also configure 'load balancing' at the switch, otherwise it won't work.


At the switch side, configure the following on the ports where this server is connected.



interface fx/x

channel-group x mode on


Note, replace the x in the channel-group with the port-channel number you want to use for this implementation. You also need to do this command on both ports at the same time if possible. Do this procedure during a maintenace window


HTH,


__


Edison.

S. Hasan Fri, 05/16/2008 - 00:45
User Badges:

NIC's of this server are conected with two diffreent switches.and both switches could not communicate with each other.

can you please assist me that how can i configure load balancing.


or is there any other solution if any



thanx - raheel





Edison Ortiz Fri, 05/16/2008 - 04:58
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

this server are conected with two diffreent switches


Well, that changes the whole design suggestion. It can't be done. Please disable the load-balancing in the server to avoid the mac-address flapping in your switch network.


I'm not a server guy but I believe you can enable some kind of load-balancing in the server without sending the same MAC address to the switch. I believe the option is fault-tolerance or load-sharing.


HTH,


__


Edison.

Actions

This Discussion