Help needed: ADSL connection problem with VRFs

Unanswered Question
May 14th, 2008
User Badges:

Hello,

I have a problem with my internet connection. I have a few internet connections of ADSL and each one is in a different VRF, when I try to connect with all of them at the same time it doesn't work, when I connect them separately, just one it works


My configuration:

ip vrf lan

rd 100:1

route-target import 100:1

route-target import 200:1

route-target import 300:1

route-target import 400:1

route-target import 500:1

!

ip vrf vrf1

rd 200:1

route-target import 200:1

route-target export 200:1

route-target export 100:1

!

ip vrf vrf2

rd 300:1

route-target import 300:1

route-target export 300:1

route-target export 100:1

!

ip vrf vrf3

rd 400:1

route-target import 400:1

route-target export 400:1

route-target export 100:1

!

ip vrf vrf4

rd 500:1

route-target import 500:1

route-target export 500:1

route-target export 100:1

!

!

interface ATM0/0/0

description FORWARDING_DIALER_01

ip vrf forwarding vrf1

no ip address

ip flow ingress

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/48

pppoe-client dial-pool-number 1

!

!

interface ATM0/1/0

description FORWARDING_DIALER_02

ip vrf forwarding vrf2

no ip address

ip flow ingress

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/48

pppoe-client dial-pool-number 2

!

!

interface ATM0/2/0

description FORWARDING_DIALER_03

ip vrf forwarding vrf3

no ip address

ip flow ingress

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/48

pppoe-client dial-pool-number 3

!

!

interface ATM0/3/0

description FORWARDING_DIALER_04

ip vrf forwarding vrf4

no ip address

ip flow ingress

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/48

pppoe-client dial-pool-number 4

!

!

interface Dialer1

ip vrf forwarding vrf1

no ip address

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username ########## password 0 ##########

!

interface Dialer2

ip vrf forwarding vrf2

no ip address

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 2

dialer-group 2

ppp authentication pap callin

ppp pap sent-username ########## password 0 ##########

!

interface Dialer3

ip vrf forwarding vrf3

no ip address

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 3

dialer-group 3

ppp authentication pap callin

ppp pap sent-username ########## password 0 ##########

!

interface Dialer4

ip vrf forwarding vrf4

no ip address

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 4

dialer-group 4

ppp authentication pap callin

ppp pap sent-username ########## password 0 ##########

!

!

ip classless

ip route vrf lan 0.0.0.0 0.0.0.0 Dialer1

ip route vrf lan 0.0.0.0 0.0.0.0 Dialer2

ip route vrf lan 0.0.0.0 0.0.0.0 Dialer3

ip route vrf lan 0.0.0.0 0.0.0.0 Dialer4

ip route vrf lan 192.168.0.0 255.255.0.0 192.168.201.1

!

ip http server

no ip http secure-server

ip nat inside source route-map adsl1 interface Dialer1 vrf lan overload

ip nat inside source route-map adsl2 interface Dialer2 vrf lan overload

ip nat inside source route-map adsl3 interface Dialer3 vrf lan overload

ip nat inside source route-map adsl4 interface Dialer4 vrf lan overload

!

access-list 1 permit any

access-list 2 permit any

access-list 3 permit any

access-list 4 permit any

!

route-map adsl2 permit 10

match interface Dialer2

!

route-map adsl3 permit 10

match interface Dialer3

!

route-map adsl1 permit 10

match interface Dialer1

!

route-map adsl4 permit 10

match interface Dialer4

!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Wed, 05/14/2008 - 10:21
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

What do you have vrf for? If the goal is just to use all circuits at same time, that is not necessary.

Beside that, the nat router map should also map an ACL, not just interface.

omeravrech Wed, 05/14/2008 - 10:44
User Badges:

So what do you recommend to config it?


By the way, I have 9 links, not 4 like i wrote. because of the capacity check I can't write them all

omeravrech Wed, 05/14/2008 - 23:16
User Badges:

I have 9 users to my ISP and because of this I have done the 9 VRFs. I need that all of my 9 users work together in a load-balancing mode.

paolo bevilacqua Wed, 05/14/2008 - 23:27
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You don't need VRF for that.

paolo bevilacqua Thu, 05/15/2008 - 00:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You have then a configuration problem, because it is known to work.

omeravrech Thu, 05/15/2008 - 02:12
User Badges:

this is the reason that I ask you. can you give me a configuration's example? cuz' I don't know what to do anymore...

paolo bevilacqua Thu, 05/15/2008 - 03:30
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Post your own once has been cleared of all vrf stuff.

omeravrech Mon, 05/19/2008 - 03:42
User Badges:

hello again... sorry on the delay....

anywhere, i try to config it without vrfs:


interface ATM3/0/0

description FORWARDING_DIALER_05

no ip address

ip flow ingress

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/48

pppoe-client dial-pool-number 5

!

!

interface Dialer5

description Phone: ###########

ip address negotiated

ip mtu 1492

ip nbar protocol-discovery

ip flow ingress

encapsulation ppp

ip route-cache flow

dialer pool 5

dialer-group 5

ppp authentication pap callin

ppp pap sent-username ########### password 0 ##########

!


but it's still not working. it is even not trying to create a session with the other side...

paolo bevilacqua Mon, 05/19/2008 - 03:48
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

For sure you're missing "ip nat outside" in dialer interface.

Then check first if the interface is connected with "show dsl interface".

Actions

This Discussion