rate-limit command issue

Unanswered Question
May 15th, 2008

i applied rate-limit input cmd on a 2 Mbps Serial Interface so as to restrict the customer traffic to 128 Kbps.attached is the int config and the ping response when i tried to ping the other end of this serial int.i got a lot of drops.i tried all the possible options of bc and be value in rate-limit cmd but still get packet drops/intermitent RTO's.without applying rate-limit i am not getting even a single packet drop but that way i am not able to restrict the customer traffic to 128 Kbps.can anybody suggest what could be the problem and is there any other way around to limit this traffic to 128 Kbps.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
bvsnarayana03 Thu, 05/15/2008 - 02:46

Because you are restricting traffic to a specific rate, you see drops when traffic exceeds beyond the configured rate. So whats the problem. its behaving the way you want.

sushilpandita78 Thu, 05/15/2008 - 22:47

Even if i put a normal ping with a repeat count of 1000 without increasing byte size , still i see a lot of packet drops.load on the link that time is hardly 20 kbps whereas i have restricted it to 128 kbps, so it should not show any packet drops.see the newly attached sh int command output in file.

cisco_lad2004 Thu, 05/15/2008 - 02:59

yoy could try to shape traffic, which is not as aggresive as policing with regards to drops, but slightly more CPU demanding.

with shaping you will buffer before dropping.

but as per previous poster replied, this is the expected behaviour of policing or rate limiting.

Pls rate all helpful posts


Joseph W. Doherty Thu, 05/15/2008 - 04:28

Agree with prior posters. Policer likely working as it should; shaper likely would be better.

The primary reason the shaper would be better, they usually seem to implement FQ (WFQ?), so when there's congestion, low volume traffic less likely to be dropped, such as your test pings.

One issue moving to a shaper, I see you're doing inbound policing, and I think a shaper might only work outbound.

Pravin Phadte Thu, 05/15/2008 - 06:12

Hi sushil,

Let me explain you how this thing works.

1st You want to limit total 128 K on that interface considering it i have provided the config.

rate-limit input 128000 16000 16000 conform-action transmit exceed-action drop

The first bps is calculated in Average rate in bits per second.

The 2nd and the 3rd vlaue is calualted in bytes.

So its Bits and then Bytes and bytes.

The above config will let you 128 K bandwidth input rate. and will burt to 128 and will drop if goes above 128.

I would suggest to apply a output rate also with this configuration.

as per your config it should have been this way.

rate-limit input 128000 8000 8000 conform-action transmit exceed-action drop

I have gone through what you have.

Let us know if this helps

Pravin Phadte Fri, 05/16/2008 - 00:47

have you tried this one.

rate-limit input 128000 16000 16000 conform-action transmit exceed-action drop

in which the the link can burts up to 128 K your burst is up to 64 K. The last option says if above 128 K drop the packet.

This is one of the option.

I work on rate limit by creating subinterface and providing rate limit to a specfic ip adddress range.

It works fine for me.


This Discussion