1841, Multiple ISPs, No BGP, Multiple NAT Problems

Unanswered Question
May 15th, 2008

Hi,

I've done research on the 'net and found other people that have done this, but I can't get it to work properly.

Please see attached config - I've got a LAN interface, 1 eth WAN interface & 1 DSL WAN interface.

I'm wanting to NAT out the eth WAN (FE0/1, ISP1) primarily, and out the DSL WAN (Dialer0, ISP2) in the event of a failure.

I've got the tracking, routing etc all working fine, so long as I do the NAT for int FE0/1 on an upstream box. If I mark it as 'nat outside' and put in the nat command (I've marked these on the config with <<<< and they're commented out) it won't fail over and the next time connectivity changes all traffic stops, and never starts again (until I take the nat commands back out for int FE0/1).

It also works vice versa, if I have the NAT commands in for int FE0/1, and removed for the Dialer0 it's fine (Traffic flows on the FE0/1 interface, of course it won't flow on the Dialer0 without NAT).

Really confused, any help would be much appreciated.

Regards,

Ben.

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mrgadgetnz Thu, 05/15/2008 - 03:54

Excellent document, thank you for that. I'll merge that config together with what I have and post back here how it goes (will be 12-15hrs before I'm back in front of this router).

Cheers,

Ben.

mrgadgetnz Thu, 05/15/2008 - 13:07

Hi,

I've tried the attached config based on the OER page and I still have exactly the same issue described in my first post.

Any more ideas are much appreciated!

Cheers,

Ben

Paolo Bevilacqua Thu, 05/15/2008 - 14:01

Can you please add "source x.x.x.x" in ping statement. I have a feel that track never fails hence route via ethernet is never removed. Please check status of "show ip route" in the various possible situations.

Beside that, oer is missing from the latest config you sent.

mrgadgetnz Thu, 05/15/2008 - 18:43

My mistake, I'm not sure what I need to add - I transposed as much of the config off that page as I could.

The track is failing - it says so at the console. If I have the FE0/1 connection routed instead of NAT'd then everything work as expected, its only when I try and enable "ip nat outside" on FE0/1 and put in the "ip nat inside..." statement that everything binds up and stops working.

Cheers,

Ben.

mrgadgetnz Fri, 05/16/2008 - 01:44

I've gone back to that link and I can't see what you mean by the OER keyword in the NAT statements:-

From the link:

ip nat inside source route-map fixed-nat interface Dialer0 overload

ip nat inside source route-map dhcp-nat interface FastEthernet0 overload

Mine:

ip nat inside source route-map ISP1 interface FastEthernet0/1 overload

ip nat inside source route-map ISP2 interface Dialer0 overload

Ok the route-maps have different names, but aside from that?

I hope I'm not missing something obvious here and apologise if I am.

Cheers,

Ben.

mrgadgetnz Fri, 05/16/2008 - 14:37

Ok, done that, no difference still...

I also tried upgrading the ISO to 12.4.15 T5, still the same.

I'm sure this must be possible....

Cheers,

Ben.

Actions

This Discussion