No Ring back tone from Unity

Unanswered Question
May 15th, 2008
User Badges:

Hello All,


I need some help on this issue.


We have a SIP trunk for Incoming & Outgoing calls connected on 3845 Router (IOS 12.4). The SIP gateway & CCM 6.0 has a H323 trunk and we are using Unity 5.0.


The problem here is when someone calls the Main number it goes to Auto Attendant. If some dial the extension number the call is transferred but there is no ring back tone sent to the caller. The IP phone rings and if no answer it goes to the Voicemail and the caller hears the greeting.


Incoming calls to DID are working fine with ringback tone heard by the caller.


I think it could be a codec issue. Not sure.


Please help.


Thanks,

Yogesh

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
yogesh.mhatre Mon, 05/19/2008 - 12:21
User Badges:

Does anyone has experience this issue?

Please help.


I am also opening a trouble ticket with TAC.


Thanks,

Yogesh Mhatre

rschwendeman Tue, 06/17/2008 - 05:09
User Badges:

Did you find a solution for the ringback on a transfer, I am running into the same issue.

yogesh.mhatre Tue, 06/17/2008 - 06:42
User Badges:

Hello All,


Apologizes for not reply for so long, was tied up with other critical issues.


The No RINGBACK TONE problem has been resolved. Here is the solution,


Set up a Send H225 User Info Message service

parameter for Cisco CallManager service in CallManager. Perform the

following steps:


* In Cisco CallManager Administration, select Service > Service

Parameter.

* Select the correct server from the drop-down list.

* Set the service to Cisco CallManager.

* In the Send H225 User Info Message field, under the Cluster Wide

Parameters (Device - H323) section, select H225 Info for Ring Back.

* Reset the H.323 voice gateway.


You also have to restart the Call Manager service on all nodes.


Thanks all for your help.


Regards,

Yogesh Mhatre

mezcalito Wed, 04/14/2010 - 17:46
User Badges:

I have the same problem, I selected the  H225 Info for Ring Back option in Call Manager, restarted both CCM and GW but that didnt fix the issue, is there any workaround to make the ring back work between the GW and Unity Connection?


Regards.

yogesh.mhatre Wed, 04/14/2010 - 19:08
User Badges:

You can try this..

On Gateway Call Manager dial-peer voip, add progress-ind enable 8.


See thats fixes the issue..


One more thing you need to restart services on all nodes.


Let me know.

mezcalito Wed, 04/14/2010 - 19:55
User Badges:

I restarted the service and didnt work with that, I found this link https://supportforums.cisco.com/message/2016666 that says that selecting "Use ANN for Ring Back" could also work, ill try tomorrow Im working at home right now and dont wanna restart the service unless im there, you never know what could happen.


By the way, I tried the command you talked about and it doesnt work in the CLI, the only command I can issue is progress_ind setup enable 3 and that also didnt work.


GW-VOZ-PALACIO(config-dial-peer)#progress_ind ?
  connect     Set Progress Indicator for CONNECT
  disconnect  Set Progress Indicator for DISCONNECT.  For use on ISDN calls,
              where disconnect tone is needed, before alert/progress/connect is
              received.
  progress    Set Progress Indicator for PROGRESS
  setup       Set Progress Indicator for SETUP


GW-VOZ-PALACIO(config-dial-peer)#progress_ind setup enable 8
                                                           ^
% Invalid input detected at '^' marker.


GW-VOZ-PALACIO(config-dial-peer)#progress_ind setup enable ?
  <0-3>  Value for PI (can be only 0, 1 or 3)


My IOS Version is c3825-adventerprisek9-mz.124-24.T.bin


I'll restart the service tomorrow.


I have CCM 7.1.3 and CUC 7.1.3


In the meantime what else could I try?


Regards.

mezcalito Wed, 04/14/2010 - 20:12
User Badges:

All right, something worked, not exactly the ring back tone, I can hear now the Music on Hold.


These are my Call Handlers:

Operator-Greeting

Operator-Transfer


The call comes to Operator Greeting, if the person enters the extension number they want to reach it does so, still dont hear the ring back nor moh

If the person doesnt enter any extension, after the greeting it gets redirected to the Operator-Transfer, there I have the next:

Transfer Rules ->Alternate-> My operator extension ->Supervise Transfer  and "Put callers on hold without asking".


Well, I could use that MOH, but Id still need to hear it when the user enters the extension in the first greeting and that doesnt work at all.


Regards.

yogesh.mhatre Thu, 04/15/2010 - 05:13
User Badges:

try using command progress_ind progress enable 8.... i don

't remember the exact command.. but it should be definately progress_ind progress...


Sometimes the call manager is not able to generate the ring back tone... the above command tell the gateway to send a ring back tone to the caller.


Let me know how it goes...

mezcalito Thu, 04/15/2010 - 14:27
User Badges:

I just discovered something... I get the ring back tone with an E1-R2 without any problems, I didnt put any additional command in the GW that has the E1 and it works!! I just selected H225 User Info Message field in the CCM.


By the way, the command that you suggested I found it here but as I told you I did not add anything in the GW with the E1.


I forgot to mention that in the main site where the Unity Connection is located I have a Sip Trunk,  the DID that redirects to the Auto Attendant comes from that Sip Trunk, do I need some extra commands to get the ring back tone?


Regards.

Actions

This Discussion