Configuring Unity to support Multiple Exchange servers

Unanswered Question
May 15th, 2008

They are using CM v4.x and Unity 4.0(5). They were using Exchange 2003 and moved their mailboxes to a new Exchange 2003 server. The mailboxes have been moved to the new server. They weren't sure what to do on the Unity side. He wants Unity to support multiple Exchange servers. So some users are on one Exchange server and other users are on a different Exchange server. These are the steps I took:

1) Ran DBWalker on Unity.

2) Ran DiRT to backup current configurations.

3) Ran the Permission Wizard on Unity to give permissions to new Exchange 2003 server and directories/subdirectories.

4) Ran the Message Store Configuration Wizard and pointed it to new Exchange 2003 server. (not sure if I did this correctly)

Some users are working fine. When left a message, their MWI lights and they receive the notification in their email. Some users, when left a voicemail, it doesn't appear to go in their mailbox. When you check it by phone, they have no new message and they don't receive a email notification either.

Also, in the Unity Administration pages, on each Subscribers Profile page, it still shows the old Exchange server.

Any ideas? Appreciate any help.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jaime Valencia Thu, 05/15/2008 - 20:34

try running the PW and MSCW again, (fully, not the -sync option if possible)

also verify that the DC/GC is the right one for the unity server and try a full resync.

which users do work? the ones that are located in the partner exchange?



if this helps, please rate

Tommer Catlin Thu, 05/15/2008 - 20:38

Couple things to check

Make sure the Unity Server is running the same version Service Pack for Exchange.

System Management tools for Exchange should be the same version as the Exchange servers.

Since you do not see the updated Subscribers Profile page with the new Exchange server, the SQL has not picked up the changes in AD, which means it's probably not syncing for some reason.

Go ahead and stop the Unity services. (in the Tray right click and stop, then after all is stopped, start the services. )

ranpierce Fri, 05/16/2008 - 13:30

2 things that I can think of right away to look at.

Can you see all the servers and mailstores in exchange system manager on the unity?

Run PW and choose the servers and mailstores that home unity subscibers.



This Discussion