multicast working only in one direction

Unanswered Question
May 16th, 2008

I have a problem that it seems that my multicast traffic is only working in one direction over the WAN.

In addition to the application that we are using, i am also using a tool that generate mcast traffic.

It appears that the traffic is only one directional.

What could be the problem?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shivlu jain Fri, 05/16/2008 - 23:38

please let us know are u using multicast on ipv4 or on mpls.

regards

shivlu

Tshi M Sat, 05/17/2008 - 05:12

IPv4

It works fine for Chicago to New York but not from NY to Chicago. I am using the same hosts for the test.

Harold Ritter Sat, 05/17/2008 - 07:34

Etienne,

Could you please let us know a bit more about the topology. Do you use PIM sparse mode? Where is the RP located? Have you done a bit of troublshooting? If so, please let us know what steps you

Regards,

Tshi M Sat, 05/17/2008 - 15:40

we are running ip pim-sparse-dense mode and the rp is located in ny. As part of troubleshooting, we used multicast tools (mdump and msend). We also used commands such as: sh ip pim rp mapping, sh ip mroute x.x.x.x, sh ip pim ne, etc.....

I am just surprised that it works one way and not the other.

Harold Ritter Sat, 05/17/2008 - 17:25

Etienne,

This is still too vague. It doesn't mean that because it works in one direction that it will in the other. I would recommend troubleshooting specifically why it doesn't work in that one direction. Here are some multicast troubleshooting tips:

- Does the router connected to the source register the S,G properly with the RP?

- Do the receiver(s) succesfully send the IGMP host membership report message?

- Do the last hop router send the PIM joing towards the RP?

Regards,

Tshi M Sat, 05/17/2008 - 20:27

Yes, the source switches register the info:

NY45B00#sh ip mroute 239.255.46.25

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

L - Local, P - Pruned, R - RP-bit set, F - Register flag,

T - SPT-bit set, J - Join SPT, M - MSDP created entry,

X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel

Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.255.46.25), 00:00:29/stopped, RP 10.33.63.1, flags: SP

Incoming interface: GigabitEthernet1/7, RPF nbr 10.33.94.6, RPF-MFD

Outgoing interface list: Null

(10.33.66.18, 239.255.46.25), 00:00:29/00:02:59, flags: PT

Incoming interface: Vlan104, RPF nbr 0.0.0.0, RPF-MFD

Outgoing interface list: Null

No, it does not look like the receiver is sending imgp host membership report unless I forced the ip join-group 239.255.46.25 on its interface. Even still the host is not receiving the mcast. Below is an out of the debug ip igmp snooping

Yes it is but for the wrong group. See attached output of debug ip pim

Harold Ritter Sun, 05/18/2008 - 07:17

Etienne,

The command "ip igmp join-group" is intended for the router to receive the mcast stream. If you wanted to send the mcast stream down the interface where the receiver is connected, you would need to used the command "ip igmp static-group"

Is PIM configured on the interface where the receiver is connected? Can you please do a "show ip igmp group detail" and "show ip mroute" on the router connected to the receiver.

Regards,

Tshi M Sun, 05/18/2008 - 17:06

Sure thing. Also, the output when the sender was sending mcast in group 239.255.46.11 port 46010. the receiver never received the packets:

sh ip mroute

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

L - Local, P - Pruned, R - RP-bit set, F - Register flag,

T - SPT-bit set, J - Join SPT, M - MSDP created entry,

X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel

Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.255.255.254), 00:03:59/00:02:56, RP 10.33.63.1, flags: SJC

Incoming interface: Vlan400, RPF nbr 10.33.242.2

Outgoing interface list:

Vlan202, Forward/Sparse-Dense, 00:03:59/00:02:56, H

(*, 239.50.0.1), 00:01:35/00:01:25, RP 10.33.63.1, flags: SP

Incoming interface: Vlan400, RPF nbr 10.33.242.2

Outgoing interface list: Null

(*, 224.0.1.39), 00:01:22/00:01:37, RP 10.33.63.1, flags: SP

Incoming interface: Vlan400, RPF nbr 10.33.242.2

Outgoing interface list: Null

(*, 224.0.1.40), 00:04:37/stopped, RP 10.33.63.1, flags: SJPL

Incoming interface: Vlan400, RPF nbr 10.33.242.2

Outgoing interface list: Null

(10.33.85.3, 224.0.1.40), 00:04:36/00:02:25, flags: PL

Incoming interface: Vlan400, RPF nbr 10.33.242.2

Outgoing interface list: Null

(10.33.94.6, 224.0.1.40), 00:04:36/00:02:25, flags: PL

Incoming interface: Vlan202, RPF nbr 10.33.240.98

Outgoing interface list: Null

(10.33.94.10, 224.0.1.40), 00:04:36/00:02:25, flags: PL

Incoming interface: Vlan202, RPF nbr 10.33.240.98

Outgoing interface list: Null

(10.33.95.3, 224.0.1.40), 00:04:10/00:02:55, flags: PL

Incoming interface: Vlan202, RPF nbr 10.33.240.98

Outgoing interface list: Null

(63.76.181.19, 224.0.1.40), 00:04:36/00:02:25, flags: PL

Incoming interface: Vlan400, RPF nbr 10.33.242.2

Outgoing interface list: Null

(65.199.176.131, 224.0.1.40), 00:04:36/00:02:25, flags: PL

Incoming interface: Vlan400, RPF nbr 10.33.242.2

Outgoing interface list: Null

(65.199.176.195, 224.0.1.40), 00:04:36/00:02:25, flags: PL

Incoming interface: Vlan400, RPF nbr 10.33.242.2

Outgoing interface list: Null

ILCBOE3SC01#sh ip igmp grou de

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,

SS - Static Source, VS - Virtual Source

Interface: Vlan202

Group: 239.255.255.254

Flags:

Uptime: 2d01h

Group mode: EXCLUDE (Expires: 00:02:50)

Last reporter: 10.33.240.102

Source list is empty

Interface: GigabitEthernet1/3

Group: 224.0.1.40

Flags: L U

Uptime: 7w0d

Group mode: EXCLUDE (Expires: 00:02:09)

Last reporter: 10.33.240.5

Source list is empty

Harold Ritter Sun, 05/18/2008 - 18:37

Etienne,

The problem lies right there. What interface is the receiver connected to? Can you provide a "show runn int " for that interface.

Regards,

Tshi M Sun, 05/18/2008 - 18:46

Hello Hritter,

Thanks much here. I really hope we can nail this.

Building configuration...

Current configuration : 169 bytes

!

interface GigabitEthernet0/13

switchport access vlan 202

switchport mode access

duplex full

speed 1000

link state group 1 downstream

spanning-tree portfast

end

waleed_amer Sun, 05/18/2008 - 23:42

Hi,

i think you need to configure PIM on physical interface, PIM under VLAN not enough to let the router processes igmp requests.

Regards,W.Amer

Tshi M Mon, 05/19/2008 - 03:14

Hi Amer,

I tried to add "ip igmp snooping" under the interface but it did not seem to take it. the command sho igmp snooping only shows vlan being active.

Harold Ritter Mon, 05/19/2008 - 04:38

Etienne,

Can you please post the output for "show runn int vlan202".

Regards,

Tshi M Mon, 05/19/2008 - 04:41

Sure thing:

Current configuration : 341 bytes

!

interface Vlan202

ip address 10.33.240.98 255.255.255.224

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-dense-mode

standby ip 10.33.240.97

standby preempt

standby authentication VLAN202

end

Current configuration : 363 bytes

!

interface Vlan202

ip address 10.33.240.99 255.255.255.224

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-dense-mode

standby ip 10.33.240.97

standby priority 150

standby preempt

standby authentication VLAN202

end

Harold Ritter Mon, 05/19/2008 - 05:51

Etienne,

I would definitely check with the application, as the only IGMP host membership report received on vlan202 is for

239.255.255.254 and from 10.33.240.102. Is this the host you are using for testing purposes?

Interface: Vlan202

Group: 239.255.255.254

Flags:

Uptime: 2d01h

Group mode: EXCLUDE (Expires: 00:02:50)

Last reporter: 10.33.240.102

Source list is empty

Regards,

Actions

This Discussion