Voice VLAN

Unanswered Question
May 17th, 2008
User Badges:

Hi,

I wanna clarify few things on the voice vlan;

1) I am going to use 1000+ phones on my new work and my current configuration is;

interface GigabitEthernet0/1

description PHONE D104

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

speed 100

duplex full.

The native VLAN is for the PC. But is it a good configuration. Now i am planning to put voice vlan.


Which configuration will be good, trunk or voice.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mahmoodmkl Sat, 05/17/2008 - 22:01
User Badges:
  • Gold, 750 points or more

Hi


i think it will be good to define seprate vlans for both data and voice.And in u r above config u havent defined the voice vlan.


intergace gig/0/1

switchport mode access

switchport access vlan 4

switchport voice vlan 10

spanning-tree portfast


Thanks

Mahmood

drnteam Sat, 05/17/2008 - 22:14
User Badges:

Thanks mahmood,


My current setup is not having a voice VLAN as it is configuring on the phone. (specifying the vlan on phone).


But now i am planning to put the voice vlan, does a mls qos is necessary for IP phones.

Justin Brenton Sun, 05/18/2008 - 14:08
User Badges:
  • Silver, 250 points or more

Hi Drnteam,


You should definately use Voice vlan's. If you don't you will most likely have voice quality issue's.


http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_se/configuration/guide/swvoip.html


Just add this to your config on your interfaces if you are using Cisco IP Phones.


Make note of the prompt #.


Config#mls qos


interface FastEthernet1/0/4

description IP Phone/Data Port

switchport access vlan xx

switchport mode access

switchport voice vlan xx

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree bpduguard enable




HTH, Please rate


Regards,

Justin Brenton


Actions

This Discussion