Portchannel and Trunk inconsistency

Unanswered Question
May 18th, 2008
User Badges:

Dear All,


Hi, I have to Cisco WS-4506 acting as Core in my production network. There are multiple L2 vlans and SVIs created on both of the switches with one switch acting as primary for one VLAN and other acting as secondary for one VLAN (I am running HSRP on per VLAN for redundancy for LAN). Both Switches are connected through one Fiber trunk on their Supervisor card and additionally 2 Gig ports are part of Etherchannel as well on each of the switch.

Please clarify if there will be any spanning tree issue or any inconsistency due to having L2 Etherchannel and additionally L2 Fiber trunk. Because I am facing issue with my Primary Core switch repeatedly. At times my primary core switch stop functioning and throws following log messages on console:


%% Low on memory; try again later


%% Low on memory; try again later


%% Low on memory; try again later


%% Low on memory; try again later


After this any type of traffic can't flow from my Primary switch and Secondary switch can't takeover.


Please find the attached logs and snapshot of configuration at both switches from my secondary core switch when the problem occurs at Primary switch. I can't login to my primary core switch when its in middle of the problem but it starts functioning after I restart it.


Should I disable Logging buffer to avoid memory problem in my Primary core switch or what will be the ideal solution!


Appreciate your earliest reponse!




Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
royalblues Mon, 05/19/2008 - 01:08
User Badges:
  • Green, 3000 points or more

Under very low memory conditions, IOS does not allow console/telnet connections to the device


disabling unnecessary processes should help in reducing the memory


you can try disabling buffer logging and instead send the logs to a syslog server.

Also there are a lot of port flapping messages which might point to a spaning tree loop. Try to fix them as well


Have a look at this Bug ID CSCed65890


Narayan

samuneer123 Mon, 05/19/2008 - 02:05
User Badges:

Dear Narayan,


Thanks for the reply. But isn't anything wrong with design of connecting Fiber trunk port on Supervisor card and also two Gig ports from each of the switch in L2 port channel /Etherchannel acting as trunk at the same time.


What about the mismatch of the configuration of between members of the Portchannel between switches. Shouldn't I allow the same Vlan range in the trunk on both of the switches.


*****************************************

Primary core Switch:


interface GigabitEthernet3/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2-4094

switchport mode dynamic desirable

channel-group 1 mode desirable

!

interface GigabitEthernet3/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2-4094

switchport mode dynamic desirable

channel-group 1 mode desirable

!

!

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport mode dynamic desirable


Secondary Core Switch:


!

interface GigabitEthernet3/1

switchport trunk encapsulation dot1q

switchport mode dynamic desirable

channel-group 1 mode desirable

!

interface GigabitEthernet3/2

switchport trunk encapsulation dot1q

switchport mode dynamic desirable

channel-group 1 mode desirable

!

!

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport mode dynamic desirable

!

************************************


Is the same thing which is causing the frequent port flap messages between Vlan1 and Vlan 2 (see the attached file for logs).


Appreciate more responses!!



With regards,


Sarfaraz



bava_ccna Mon, 05/19/2008 - 02:29
User Badges:

Hi


i am also getting same flapping error in my Cisco 4506 switch.Initially i suspect that there might a loop in our network and again i found that there is no such loops in my network


Any help is appreciated


Cheers

Bava

samuneer123 Mon, 05/19/2008 - 04:28
User Badges:

Dear All,


I have looked at the TAC Bug toolkit.


CSCed65890 Bug Details

Request to have ability for reserving memory for exec session


Workaround:

No workaround


Can anybody tell me how can I allocate necessary memeory for exec session to avoid running into Low on memory problem ?


With Regards,


Sarfaraz


samuneer123 Mon, 05/19/2008 - 05:08
User Badges:

Dear muca,


This document doesn't relate to the problem that I am facing with these switches.


I am facing difficulty to find the exact root cause of this problem.


With regards,


Sarfaraz

rmujeeb81 Mon, 05/19/2008 - 07:28
User Badges:


Dear Sarfaraz,


If you think that there is something goes wrong with spanning tree then you can only use the ether channel between these switches. Few other steps you can take to prevent additional messages/packets forwarding between both switches like,


- Disable DTP on all trunk links and manually configure trunks on both side.

- Manualy configure etherchannel to avoid negotiation by PAGP on both sides.


Regards,


Mujeeb

samuneer123 Mon, 05/19/2008 - 09:03
User Badges:

Dear Mujeeb,


Thanks for your input. Thats what I did right now for only etherchannel configuration and Fiber trunk port (which is not part of Portchannel) for rest of the port configuration I will do it soon. Initially the only reason I suspected was spanning tree loop causing frequent flaps as per seen through log but this design with Fiber trunk port with additional Portchannel (2 member Gig ports on GBIC-LAN module) is running fine since so long.


This "Low on memory" issue is re-ocurring frequently once every 3 weeks atleast causing service disruption.


I will lock down DTP and other unnecessary services then analyze if things are getting better!

Actions

This Discussion