Configuration Fatality ISP

Unanswered Question
May 19th, 2008
User Badges:

Regards to all, I have a problem at the moment of forming the connection of my supplier of Internet. I have proved everything possible but all the results are negative.

The parameters of configuration are:

VPI:8 VCI:32 IP: 80.80.80.80/24 Encap: MAC Encapsulated Routing Someone can help me with this problem.


Pardon for my English :(

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Mon, 05/19/2008 - 02:10
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

bridge irb

bridge 1 route ip


int atm0

no ip address


int atm0.1 point-to-point

no ip address

bridge-group 1

pvc 8/32


int bvi1

ip address ..

ip nat outside


hope this helps, please rate post if it does!

nachogdiaz Mon, 05/19/2008 - 02:32
User Badges:

Hello p.bevilacqua!, thank you for helping myself but I continue without coming to Internet.

I put a sh run:


version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

crypto pki trustpoint TP-self-signed-1935357841

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1935357841

revocation-check none

rsakeypair TP-self-signed-1935357841

!

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool sdm-pool

import all

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

lease 0 2

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

no ip domain lookup

ip domain name yourdomain.com

!

!

!

!

!

archive

log config

hidekeys

!

!

!

bridge irb

!

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

pvc 8/32

!

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.248

ip tcp adjust-mss 1452

!

interface BVI1

ip address X.X.X.X 255.255.255.0

ip nat outside

ip virtual-reassembly

!

ip forward-protocol nd

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

access-list 23 permit 10.10.10.0 0.0.0.7

no cdp run

!

!

!

control-plane

!

bridge 1 route ip

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end


That can be failing?

paolo bevilacqua Mon, 05/19/2008 - 02:49
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hola,


You are missing:

- "bridge-group 1" under atm0.1

- default route like 0.0.0.0 0.0.0.0 x.x.x.x

- ip nat inside source list XX interface bvi1 overload

- and ACL for the above


Also check that you're connect in first place with "show dsl interface".

nachogdiaz Mon, 05/19/2008 - 03:09
User Badges:

I also meet very lost

I have put this configuration but it continues without working.



version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool sdm-pool

import all

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

lease 0 2

!

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

no ip domain lookup

ip domain name yourdomain.com

!

!

!

!

!

archive

log config

hidekeys

!

!

!

bridge irb

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description $ES_WAN$

pvc 8/32

encapsulation aal5snap

!

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.248

ip tcp adjust-mss 1452

!

interface BVI1

ip address X.129.224.68 255.255.255.0

ip nat outside

ip virtual-reassembly

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 ATM0

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

access-list 23 permit 10.10.10.0 0.0.0.7

no cdp run

!

!

!

control-plane

!

bridge 1 route ip

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end



paolo bevilacqua Mon, 05/19/2008 - 03:12
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, you're entering the wrong commands. Please read my message and enter the command correctly.


nachogdiaz Mon, 05/19/2008 - 03:32
User Badges:

I am sorry, but not as put the commands that you have indicated me, you can help do it to me please

paolo bevilacqua Mon, 05/19/2008 - 03:49
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Most important is ip route 0.0.0.0 0.0.0.0 must have IP of default GW and not an interface.

nachogdiaz Mon, 05/19/2008 - 04:12
User Badges:

Hello, i configured:


ip route 0.0.0.0 0.0.0.0 ATM0.1 KO

ip route 0.0.0.0 0.0.0.0 BVI1 KO


On having done one sh ip inter brief:


Interface IP-Address OK? Method Status Protocol

FastEthernet0 unassigned YES unset up up

FastEthernet1 unassigned YES unset up down

FastEthernet2 unassigned YES unset up down

FastEthernet3 unassigned YES unset up down

ATM0 unassigned YES manual up up

ATM0.1 unassigned YES manual up up

Vlan1 10.10.10.1 YES NVRAM up up

BVI1 X.129.224.68 YES manual down down

NVI0 unassigned NO unset up up


paolo bevilacqua Mon, 05/19/2008 - 12:29
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, what I'm trying to tell you, remove the above static routes and use instead the IP address of deault gateway as communicated by the ISP.

Actions

This Discussion